1. Computer problem? Tech Support Guy is completely free -- paid for by advertisers and donations. Click here to join today! If you're new to Tech Support Guy, we highly recommend that you visit our Guide for New Members.

How do I flash my American Megatrends BIOS? I've tried everything!

Discussion in 'Hardware' started by Total Oblivion, Oct 12, 2007.

Thread Status:
Not open for further replies.
  1. Total Oblivion

    Total Oblivion Thread Starter

    Joined:
    Apr 29, 2007
    Messages:
    16
    Specs first:

    e6700 3.2 GHZ.
    4GB Patriot extreme ram (4 x 1GB) @ 800MHz and 4 - 4 - 4 - 12 T2 (T1 causes BSOD :p ).
    XFX 8800 GTS
    Asus P5N32 SLI SE Deluxe w/ ver 5## BIOS (Possibly a custom one from the OEM).

    My computer is working fine, excpet for one minor detail...

    My Asus P5N32 SLI SE Deluxe doesn't like my new 4GB of 800MHz ram. The ram is fine. XP 32 bit runs fine with only 2-3 GB in use, but Vista Ultimate 64-Bit is terrible, running at least 5 times slower and maxing out the processor and freezing a couple of minutes just to open Fire Fox. I am considering buying a new mobo, but I heard there is another way.

    Some people have gone into their BIOS and enabled an option called "Memory Remapping," which fixed the problem. The catch is: My BIOS doesn't have that option for some odd reason... Surprise, surprise after my cellphone provider had to send 2 SIM cards to me for the phone to work and my External Backup HD had failed just a couple of months after I bought it(Goodbye 100+ Gigabytes of data).

    I checked the manual that went with my mobo, and the bios version in the manual and on my computer were EXACTLY the same! Though, the menu in the Manual had many more options than did the one on my computer. So, I go to Asus's website and download the latest official (not beta) driver. Then, I pop in the Asus CD that came with my mobo and tried to run "Asus Update". Every time I run this I get an error message: "Unable to create NT driver service for BS_DEF.DLL". After I click OK (which is NOT OK, damn u windows!), another message pops up: "No ASUS motherboard Installation will be abooted now." Yes, something is OBVIOUSLY wrong here, they obviously have no idea what they're doing, even the error messages are spelled wrong! I tried again and got an error message titled "ASUS BIOSINFO.DLL" and the message was a string of sixteen or seventeen random characters. Clicking OK caused the same message as before to pop up (wanting me to ABOOT the installation...)

    The next thing for me to do was try to flash the BIOS from a floppy disk. The guide I consouled for this method told me to put their upgrade utility AND the bios update on a bootable floppy disk. I tried formatting with the MS-DOS startup disk option ticked (and after that failed, without it ticked). The computer could not boot from the floppy disk (or the other one I tried, either). The disk (1.44 MB) could not hold both the upgrade program and the updated bios file (so, I tried with just the update program on the floppy and the BIOS update on the hard disk).

    So, I tried running the update program in windows XP Pro.

    Program (AFUWIN.exe): "... close all other programs before continue."

    Me: Clicky Ok button.

    Program (AFUWIN.exe): "Error: BIOS does not support AFU."

    Me: Alt + F4


    Then, I try running the Dos version of the program in the command prompt...

    ... AMI Firmare Update Utility Ver.4.14 ... ...

    - Error: This program can not run under this operating system (not surprising, I don't think it's supposed to, but it should have at least booted from the Floppy Disk!).


    So, here I am... Please, somebody help me, I'm seriously stumped here.


    I do have another computer with its own BIOS chip. It's about 3 years old, though. The PC I'm on right now is approaching its first year, and it's a gaming rig, so I don't know what bizzare effects that might cause.

    *Edit: I removed the big AFUWIN.exe file from the disk and the bios update file fits, hopefully it boots.

    *Edit: No luck.
     
  2. Total Oblivion

    Total Oblivion Thread Starter

    Joined:
    Apr 29, 2007
    Messages:
    16
    Argh, not even a boot cd did the trick! The DOS files loaded onto the cd and the cd ran just like a floppy disk, but the BIOS files were nowhere to be found! WTF, did I use nero wrong?
     
As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 733,556 other people just like you!

Loading...
Thread Status:
Not open for further replies.

Short URL to this thread: https://techguy.org/637340

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice