How do I restore executability to .msi files after an "Open With" accident?

Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

WlvnSpectre

Thread Starter
Joined
Jun 29, 2005
Messages
11
So there I was being my relatively tech savvy self on a fresh install of Windows 2000, and just starting to decide what to install from backups, what to download, etc, etc.

I wasn't sure if the file I was looking at installing, a Microsoft Installer File (.MSI), and I knew that my handy dandy WinRAR could give me a peek.

1)right clicked on file, chose "open with"

2)selected WinRAR

3)I forgot to check the check box for always using this to open this type of file (Me am smart!) :(

4)It opens alright, and when I decided "oh yeah... I know what that is, I'm going to install that." only to find that the Icon had changed.

5)I tried "open with"ing to WinRAR making sure that that box was unchecked, and tried "open with"ing to nothing. sure the Icons changed but the .MSI file won't launch, and neither will any others (of course)

I looked from Microsoft to Computer service sites. No mention, no info.

Did I mention Me am Smart, me find way to mess up computer in three mouse clicks. :(

:( Heeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeelp! :(
 

EAFiedler

Retired Moderator
Joined
Apr 25, 2000
Messages
14,172
Hi WlvnSpectre

Welcome to Tech Support Guy Forums!

I am looking at Windows XP, hopefully Windows 2000 is similar in the steps.
Control Panel > Tools > Folder Options > File types tab

Scroll down the extension list to msi and highlight the File type.
Click Advanced
If open appears in the Actions: window, delete it.

I show the following actions for the msi file type:
Install
Uninstall
Repair

Windows Installer is listed as the program for Open with.

Let us know if that works for you or not.
 

Attachments

WlvnSpectre

Thread Starter
Joined
Jun 29, 2005
Messages
11
Thanks Alot... with a few differances it worked
Control Panel>Folder Options>File Types

Then it said in the space below the window when I selected MSI, that I had customized it. there were 2 buttons; Change and Restore. Selecting change takes me to the same window as "Open With" did. Clicking Restore reset it to Microsoft Installer.

:) :) :) Thank you EAFiedler :) :) :)

WolvenSpectre
Currently 10 - 15 yards from the Flooding Saskatchwan River (Think Canada's Mississipi River only flooding, and not so muddy)

See...Me said me am smart! :rolleyes:
 
Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 807,865 other people just like you!

Latest posts

Top