1. Computer problem? Tech Support Guy is completely free -- paid for by advertisers and donations. Click here to join today! If you're new to Tech Support Guy, we highly recommend that you visit our Guide for New Members.

HP DeskJet 3050 WiFi printer keeps going offline

Discussion in 'Networking' started by Seeker4, Jan 19, 2011.

Thread Status:
Not open for further replies.
Advertisement
  1. Seeker4

    Seeker4 Thread Starter

    Joined:
    Jan 19, 2011
    Messages:
    2
    We have an HP DeskJet 3050 wireless printer connected by WiFi to two laptops. One laptop, a Dell 700m, runs XP Pro with all updates applied. The other laptop, a Dell XPS 15, runs Windows 7 64-bit, again with all updates applied.

    The printer works completely reliably from the XP machine. From the XPS 15, the printer works reliably for a day or so, then the icon in Devices & Printers is grayed, indicating the printer is offline. Even in this condition, I can access the printer's built-in web server using Firefox on the XPS 15 and the connection appears to be fine. The printer's IP address has not changed. But the printer is still reported as offline for printing by Windows.

    The workaround is to delete the device and reinstall it using Add Printer and Have Disk, but using the already installed drivers rather than re-installing. After doing that, the printer then works for a few days before again going offline.


    Rebooting the XPS 15 does not help; cycling power on the printer does not help.


    This problem is extremely irritating. I've done Google searches on this problem. Although I've found a variety of similar reports for various brands of wireless printers on Vista or Windows 7, I've not seen a solution. My latest attempt is to share the printer on the Dell 700m and print to the shared printer from the XPS 15. We'll see if that continues to work for a few days (I suspect it will). But this isn't really a solution and not always convenient.


    Overall, this feels like some kind of driver or Win7-64 problem on the XPS 15.

    Any suggestions would be appreciated.
     
  2. TerryNet

    TerryNet Moderator

    Joined:
    Mar 23, 2005
    Messages:
    78,257
    First Name:
    Terry
    Don't know if it makes any difference, but are you saying that you use an ad-hoc wireless among the three devices; not using a wireless router or WAP?

    Kinda smells to me like a non-Windows security application issue. What one(s) do, or did, you have on the problem machine?
     
  3. Seeker4

    Seeker4 Thread Starter

    Joined:
    Jan 19, 2011
    Messages:
    2
    Both laptops are connected via a gigabit switch to a wireless router. Both laptops are part of a workgroup (not homegroup). The problem machine is the Dell XPS 15 running Windows 7-64 bit with Microsoft Security Essentials. No other firewall or security programs. I doubt the problem is a security program. Once I reinstall the printer, it works correctly, sometimes for several days, before going offline again.
     
  4. missymssy

    missymssy

    Joined:
    Jun 27, 2005
    Messages:
    3
    I have the exact same issue, but it happens with BOTH laptops-one Vista, one running Windows 7. I agree it is annoying-every other day it seems I'm reinstalling it on at least one!
     
As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 733,556 other people just like you!

Thread Status:
Not open for further replies.

Short URL to this thread: https://techguy.org/975555

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice