HP Laserjet 1020 printer problem in Vista

Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

jackgreat

Thread Starter
Joined
Jun 12, 2004
Messages
152
Hello Everyone,

I have Microsoft Windows Vista Home Premium (32-bit) installed in my Dell Laptop. The OS is upto date with all updates. I have HP laserjet 1020 plus printer but I lost the installation CD. So I downloaded the driver from HP website for Vista 32-bit.

Now I install the driver and then plug in the printer. The installation says "Successful". Now I have the printer added in the printer panel and it says Ready.
All fine so far.

But when I print a test page nothing is printed. (I have checked stuff like printer is on, paper is there and all is connected)

And in the printer window which shows number of pages and name of document etc there is nothing. If I goto a program like wordpad and print something then there is no error but printer is not printing anything. In the window which shows printer spooled docs there is no item. The print spooler service is running fine.

I dunno whats happening. Can anyone help me out.

Thanks,

JG
 
Joined
Jan 17, 2007
Messages
849
I'd go to Device Manager, uninstall the printer and then reboot the PC with the printer ON and connected.

See if Windows finds it that way!
 

jackgreat

Thread Starter
Joined
Jun 12, 2004
Messages
152
windows is able to detect it.. i successfully installed the driver also. but it does not print anything. test page print also does nothing.
 
Joined
Oct 9, 2008
Messages
7
I have the same problem with my Dell and a HP laserjer HP IIP. I had Dell take over my PC but they could not fix it. I have connected the printer back on my old Sony PC w/XP & it works fine if I use the Parrallel port . _But not if I use the USB port. I have been advised to get a new printer. I don't want to do that and neither should you. Will some one help jackgreat an me, happlyoldster. Thank you all.
 
Joined
Mar 9, 2007
Messages
159
I had the same problem. You have to follow the instructions EXACTLY. If it tells you not to connect your printer, don't have it connected. (There is a step that actually tells you to make sure it's not connected)
 

jackgreat

Thread Starter
Joined
Jun 12, 2004
Messages
152
I followed the steps exactly but it does not work. Tired of all this I installed Windows XP in another partition and installed the printer in XP.
 
Joined
Oct 9, 2008
Messages
7
Thankyou crazlunatic, As did jackgreat, I tried following the steps exactly with failure at the end of the road. I can't install XP because I don't think that will solve my problem. My Dell does not have a parallel port so I must use a Parallel to USB cable. When I connect my printer to the old Sony pc w/XP, it works fine with the regular Parallel port but fails if i use the Parallel to USB cable. I tried two different P to Usb cables.. As for jackgreat, I'm so happy for you that you found a fix. I'm thinking of going back to XP just because.
 
Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 807,865 other people just like you!

Latest posts

Members online

Top