HP tx2000: Lights on, then immediately off, no fan or hard drive...

Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

SDFOX 7

Thread Starter
Banned
Joined
Apr 28, 2007
Messages
386
I'm trying to fix a friend's laptop.

The indicator lights all come on, then immediately shut off.

However, it does seem to charge as the charging light stays on.

There's no fan or hard drive activity or noise. I'm guessing the internal power supply.

Anyone have any other suggestions? Thanks.
 
Joined
Jan 18, 2007
Messages
320
There is no internal power supply if you have the power adapter that plugs into the wall.
it sounds like a possible bad motherboard.

i would remove the parts like ram/hdd and see if it changes anything. Also remove the battery.
 
Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 807,865 other people just like you!

Latest posts

Members online

Top