1. Computer problem? Tech Support Guy is completely free -- paid for by advertisers and donations. Click here to join today! If you're new to Tech Support Guy, we highly recommend that you visit our Guide for New Members.

Huge amounts of mouse lag.

Discussion in 'Hardware' started by Dawkins, Jan 22, 2011.

Thread Status:
Not open for further replies.
  1. Dawkins

    Dawkins Thread Starter

    Joined:
    Jan 22, 2011
    Messages:
    3
    A while back now, I noticed that my mouse, which had once worked perfectly fine, started acting up. The movement of it felt slightly sluggish. I put it down to it being faulty and then went and replaced it. Anyway, this new mouse is even worse. Small movements are fine, however if I move across the mouse mat quickly, the cursor continues to move a good few centimeters after I stop. Very rapid movements barely register at all.

    As I game a lot, this is completely unacceptable. I have acceleration completely disabled within Windows using a registry tweak, so it's not as if acceleration's messing up. I've fully reinstalled windows and tested without the tweak, and it's still the same.

    Earlier, I plugged the mouse into my brother's computer and opened up TF2, tested it and it worked perfectly fine, with no lag at all. Also reset my BIOS to the default values, although I didn't even mess with it in the first place.

    Tried in a HUB; Same issue. Tried with nothing but the mouse connected as well.

    Any help at all would be appreciated here...
     
  2. norton850

    norton850

    Joined:
    Mar 8, 2004
    Messages:
    7,794
    Boot up in Safe Mode. Do you still have the problem?
     
  3. Dawkins

    Dawkins Thread Starter

    Joined:
    Jan 22, 2011
    Messages:
    3
    After a quick fiddle about with the USBs, the problem seems to now be non existent in Windows. No idea what the heck happened, but it's still very much there in every game I've tested.

    Also, just to note as well. This isn't just game lag. I know there'll be someone who'll say that, but I'm running everything at 60 fps constant.
     
As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 733,556 other people just like you!

Thread Status:
Not open for further replies.

Short URL to this thread: https://techguy.org/976345

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice