1. Computer problem? Tech Support Guy is completely free -- paid for by advertisers and donations. Click here to join today! If you're new to Tech Support Guy, we highly recommend that you visit our Guide for New Members.

Huge problem with Alfa AWUS036NH

Discussion in 'Networking' started by caballero, Jun 13, 2010.

Thread Status:
Not open for further replies.
  1. caballero

    caballero Thread Starter

    Jun 13, 2010

    My friend bought Alfa AWUS036H 2000 mW with 9 dbi areal to have a better reception with a wireless router in a big house. I myself have used Alfa AWUS036H 500 mW with 9 dbi areal and it worked perfectly. However, the new AWUS036NH underperforms terribly. If my old AWUS036H shows 80-100% signal strength/quality, new AWUS036H has barely 20-30%! I tried everything: 2 different computers, updating drivers, changing USB cables, changing areals. We even bought a second AWUS036NH thinking that the first one might be defected. It's still the same... Has anyone any idea what is wrong? OS is Windows 7.
  2. JohnWill

    JohnWill Retired Moderator

    Oct 19, 2002
    Well, maybe that is simply a poorly designed product.
  3. matyrojo666


    Jul 7, 2010
    I have the same problem!!! Did you fix it up?

    I have an Alfa Networks USB wifi card model AWUS036NH using a Ralink RT3070 chipset inside.

    I´ve tried to install my card using the included CD in Windows 7 Ultimate 32bits. I´ve also tried downloading drivers from Alfa web page and Ralink webpage for my usb card.

    All is installed but the card is disabled in Windows "lan conections". When I click on ENABLE it, it continues disabled. If I click on DIAGNOSE it sais that there´s a problem with the driver that is incompatible.

    I don´t know what else to do because I´ve also change my usb cable but the problem continues. I installed in a Windows Vista Ultimate 64 bits and the same problem with my card.

    There´s a thing I consider: the blue light in the usb card is blinking or is active, I think that means that the card is working but I can´t use it.

    Please help me to resolve this.


As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 733,556 other people just like you!

Thread Status:
Not open for further replies.

Short URL to this thread: https://techguy.org/928906