1. Computer problem? Tech Support Guy is completely free -- paid for by advertisers and donations. Click here to join today! If you're new to Tech Support Guy, we highly recommend that you visit our Guide for New Members.

Huge problems with games

Discussion in 'Games' started by Remus767, Nov 1, 2007.

Thread Status:
Not open for further replies.
  1. Remus767

    Remus767 Thread Starter

    Joined:
    Nov 1, 2007
    Messages:
    34
    Ok so here we go. Basicaly my games crash before they even get to the menu screen (there is no error message). :confused:

    It happened before i upgraded to vista so vista isnt the problem. Another thing that you might want to know is that i have a radeon x1650 graphics card, it worked great with all the games, until the radeon drivers 7.9 came out. After i installed thoes drivers the games started to crash (specificaly steam games) so i just re-installed the 7.8 drivers to fix the problem. Then i upgraded to vista and installed the latest drivers. This caused the games to crash again. But now reverting to old drivers doesn't fix the problem. (BTW my comp doesnt suck so it's not ram or processor issues)

    Below is posted the youtube link of what is happening. (i did a screen recording)(sorry i didnt know how to make it slower but it shows me trying to open games and they dont open.)(when i get to steam and open counterstrike it gets to the screen where it says loading on the bottom left hand corner and then closes)

    http://youtube.com/watch?v=g1dTobxBhjg

    Now this could be issue but i also susspect that it might be firewall, AVG antivirus, nvidia sound driver, types of software ect... I only have windows firewall, i tried disableing it and starting the games, that didn't work. I'm stumped :confused: you guys are my last resort, please help.
     
  2. McTimson

    McTimson

    Joined:
    Aug 15, 2002
    Messages:
    5,577
    When you upgraded to Vista, did you reinstall any of the games? Have you tried reinstalling before?
     
  3. Remus767

    Remus767 Thread Starter

    Joined:
    Nov 1, 2007
    Messages:
    34
    so i reinstalled the games yeah. I tried doing a clean install of my radeon drivers. Didn't work. but using the 7.6 drivers does work. So i think ill just stick with thoes and not complicate things. Thankyou for trying to help though
     
As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 733,556 other people just like you!

Loading...
Thread Status:
Not open for further replies.

Short URL to this thread: https://techguy.org/646598

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice