I think I have a bug on my Mac

Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

tomasrubeck

Thread Starter
Joined
May 3, 2010
Messages
5
Hi,

Hope you are well.

I have a Mac PowerBook G4 running 10.5.8 I am having problems getting on the net on some sites? The problem has got gradually worse through the evening...and I think I might have a bug if that is possible? When I try to get onto the net eg myspace I get my home page and then the Mac wheel starts spinning for ages and then it crashes. The same thing happens on other sites too. That is I can't get past the home page, and everything either crashes or freezes.

I bought and downloaded some software from the net yesterday and I think it has caused the problem.

Really hope you can help.

Thanks so much.
 
Joined
Oct 14, 1999
Messages
521
Almost sounds like a memory problem. make sure you are running the newest version of Safari....
 
Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 807,865 other people just like you!

Latest posts

Members online

Top