1. Computer problem? Tech Support Guy is completely free -- paid for by advertisers and donations. Click here to join today! If you're new to Tech Support Guy, we highly recommend that you visit our Guide for New Members.

Icons Appear in Wrong Color Mode

Discussion in 'Windows XP' started by RubySlippers, Dec 28, 2001.

Thread Status:
Not open for further replies.
Advertisement
  1. RubySlippers

    RubySlippers Thread Starter

    Joined:
    Dec 28, 2001
    Messages:
    18
    My computer is running Windows 2000. I installed a game (Scrabble) that is incompatible with Windows 2000. When I tried to run it, my computer switched into a different video mode (color depth, resolution, etc.). I manually switched it back, and uninstalled the game. Now, however, all my icons appear in 256 color mode even though my display properties are set to 32-bit color mode.

    I've tried changing the color mode back to 256 and then back again to 32-bit. I've tried reinstalling my video card drivers, and also tried updating them to the latest ones. I've reinstalled the drivers for my monitor. I've also upgraded to DirectX 8.1 (up from 7). I also deleted the file ShellIconCache and rebooted to recreate it. Nothing has worked. Everything else displays correctly including pictures, wallpaper, screen savers, web pages, etc.

    Any ideas?
     
  2. Rikku

    Rikku

    Joined:
    Dec 11, 2001
    Messages:
    743
    The only place I know to change that setting is in the Display Control Panel.

    Goto the Effects Tab and make sure 'Display Icons using all possible colors' is CHECKED.

    hope that helps :)
     
  3. RubySlippers

    RubySlippers Thread Starter

    Joined:
    Dec 28, 2001
    Messages:
    18
    "Display Icons using all possible colors" is checked. I unchecked it and rechecked it, but all icons are still in 256 colors.

    Any other ideas?
     
  4. eddie5659

    eddie5659 Moderator Malware Specialist

    Joined:
    Mar 19, 2001
    Messages:
    36,048
    Hiya

    When you were in Display | Settings, click Advanced. Under Troubleshooting tab, what is your Hardware Acceleration set to?

    Also, what is the full name of your Scrabble game and the name of your video card? Is there any yellow !'s in the Device Manager? Have you tried in Safe Mode to see what your display looks like?

    Regards

    eddie
     
  5. RubySlippers

    RubySlippers Thread Starter

    Joined:
    Dec 28, 2001
    Messages:
    18
    Hardware acceleration is set to Full (the highest setting). The full name of the game is "Scrabble". It's made by Hasbro Interactive. My video card is NVidia Riva TNT. There are no yellow "!" marks in Device Manager. If I boot into Safe Mode, the icons look exactly like they do in regular mode because the entire display is in 256 color mode. That's what the icons are displaying in.
     
  6. kramnnim

    kramnnim

    Joined:
    Dec 5, 2001
    Messages:
    489
    Some people were having problms with icons showing only 16 colors, but with WinXP, theres a registry setting you can add that is suposed to fix it, I dont know if it would work for you, though. Ill see if I can find it if you want to try...
     
  7. Brooks

    Brooks Guest

    Joined:
    Oct 30, 2001
    Messages:
    2,323
  8. kramnnim

    kramnnim

    Joined:
    Dec 5, 2001
    Messages:
    489
    TweakUI for XP is what was causing the icon problem with XP, but maybe it would work with 2k, =/
     
  9. RubySlippers

    RubySlippers Thread Starter

    Joined:
    Dec 28, 2001
    Messages:
    18
    I already tried repairing the icons using TweakUI, and it didn't work.
     
  10. eddie5659

    eddie5659 Moderator Malware Specialist

    Joined:
    Mar 19, 2001
    Messages:
    36,048
    Hiya

    Not sure if you still have this problem, but may have an answer. This says its for Win95, but it may work for 2000.

    Showing icons using "all possible colours" (Windows 95 only)

    This setting is required to appreciate 256 colour icons. (The Windows 95 default setting is to show icons in only 16 colours!)

    1) Make sure your display is set to 16-bit or higher (Right click on the desktop, choose Properties, click on Settings tab and adjust the Colour Palette field if necessary).

    2) Run the Registry Editor (REGEDIT.EXE).

    3) Open HKEY_CURRENT_USER\Control Panel\desktop\WindowMetrics

    4) Double click on Shell Icon BPP and change the value to either 16 or 24 (i.e. 16 or 24 bits, depending on your current settings)
    NOTE: If there is no WindowMetrics key just add it; the single entry for Shell Icon BPP will work.


    Now, I have just looked on mine, which happens to be 2000, and I have that key and 16 in the Data. I am also on 16-bit. You might want to be safer, and back up the registry before you try this.

    Regards

    eddie
     
  11. Sponsor

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 733,556 other people just like you!

Thread Status:
Not open for further replies.

Short URL to this thread: https://techguy.org/63222

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice