1. Computer problem? Tech Support Guy is completely free -- paid for by advertisers and donations. Click here to join today! If you're new to Tech Support Guy, we highly recommend that you visit our Guide for New Members.

ICS and DHCP

Discussion in 'Networking' started by Pammi1958, Jan 17, 2003.

Thread Status:
Not open for further replies.
Advertisement
  1. Pammi1958

    Pammi1958 Thread Starter

    Joined:
    Jan 12, 2003
    Messages:
    62
    I networked my pc's running WinMe peer to peer.One fine day the ICS all of a sudden stopped working. I ran the sometimes useless Help. Help told me that I had the DCHP service turned off. It said to turn on the DHCP service:

    Insert your Windows CD-ROM into the CD-ROM drive on the host computer.
    On the desktop, double-click My Computer.
    Double-click your CD-ROM drive, double-click the Tools folder, double-click the Mtsutil folder, and then double-click the ICS folder.
    Right-click the Dhcp-on file, and then click Install.
    Restart the host computer.

    HA! There is no such folder on that disk, not that I can find.
    The Win Me was pre loaded. Where am I supposed to find the file?

    :rolleyes:
     
  2. NetEngineer

    NetEngineer

    Joined:
    Jan 6, 2003
    Messages:
    51
    When you use the Help and Support Troubleshooter for Internet Connection Sharing in Windows Millennium Edition (Me), the troubleshooter may instruct you to turn Dynamic Host Configuration Protocol (DHCP) on by going to the Tools\Mtsutil\ICS folder on your Windows Me CD-ROM, but the folder is missing.
    CAUSE
    The ICS folder is not included on the Windows Me CD-ROM.
    RESOLUTION
    WARNING: If you use Registry Editor incorrectly, you may cause serious problems that may require you to reinstall your operating system. Microsoft cannot guarantee that you can solve problems that result from using Registry Editor incorrectly. Use Registry Editor at your own risk.

    To resolve this issue:
    Click Start, click Run, type regedit.exe in the Open box, and then click OK.
    Locate and click the following registry key:
    HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\ICSharing\Settings\General

    Click the EnableDHCP value in the right pane.
    On the Edit menu, click Modify. In the Value data box, type 1, and then click OK.

    Note that you can turn DHCP off by changing the data value to 0 (zero).
    On the Registry menu, click Exit.
     
  3. Pammi1958

    Pammi1958 Thread Starter

    Joined:
    Jan 12, 2003
    Messages:
    62
    Ok
    I tried but HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services is as far as it goes, there is no \ICSharing\Settings\General
    Not there maybe?
    I guess I will try uninstalling the network and starting over. (argh)
     
  4. Pammi1958

    Pammi1958 Thread Starter

    Joined:
    Jan 12, 2003
    Messages:
    62
    OK here goes........
    I uninstalled and reinstall communications in add/remove programs.
    I started up in safe mode and removed all the network adapters.
    Rebooted and reinstalled everything.
    Went back into regedit and the ics sharing folder was there, and the value was already set to 1 and enabled. When I reinstalled the ICS I got the wizard and I noticed something different. It asked for my network adapter for home, which I finally found out which one that is by the way, and asked which device connects mt to the internet. It was a choice between the ethernet adapter or dial up. I chose dial up. Maybe thats what was wrong. I won't be able to tell till I remove that dratted w32\Dupater virus off the other pc. :D
    Its been an eventful weekend.
    heh heh heh
     
As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 733,556 other people just like you!

Loading...
Thread Status:
Not open for further replies.

Short URL to this thread: https://techguy.org/113847

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice