ide/usb adapter question

Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

hatrabbit

Thread Starter
Joined
Aug 8, 2004
Messages
24
Hi all... I am attempting to connect a Maxtor hard drive to my PC via an IDE-USB adapter. I get the bubble (in XP) that the mass storage device is recognized and ready to use but it doesn't show up as a drive. What are some alternative ways I could try to connect to it? Thanks.
 
Joined
Aug 1, 2003
Messages
51,988
Is it partitioned and formatted? Does it appear in Disk Management or Device manager?

Has the drive been used before and is there anything on it?

If you are trying to recover data from it, a USB connection is not a good way to do that since BIOS can have no access to USB drives.
 
Joined
Jul 19, 2005
Messages
11,670
Post a link to the adapter you are using. How is the drive jumpered, Master, Cable Select or Slave?
 
Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 807,865 other people just like you!

Latest posts

Staff online

Members online

Top