Insignia 2.0 Speaker Troubles

Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

TheBlueLover010

Thread Starter
Joined
Nov 1, 2011
Messages
1
Hey Tech Support. So i got a bunch of viruses on my computer so my father took it to his friend at work to clean up the computer. Everything was lost which i knew already. Well i have had my Insignia 2.0 Speakers for about a year now and when i got my computer back they didnt seem to make any sound. I plugged them in correctly but my computer cant find them Please Please Please help! :(
 
Joined
Jul 13, 2010
Messages
269
Look up your sound driver, probably corrupt or missing.
Download or install from cd, it probably will start working.
 

flavallee

Frank
Trusted Advisor
Joined
May 12, 2002
Messages
83,267
It's my guess a clean reinstall of Windows XP was done, but the drivers weren't installed for all of the devices.

Right-click MY COMPUTER, then click Properties - Hardware - Device Manager.

Are there any entries with a ? or ! next to them?

--------------------------------------------------------
 
Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 807,865 other people just like you!

Latest posts

Members online

Top