1. Computer problem? Tech Support Guy is completely free -- paid for by advertisers and donations. Click here to join today! If you're new to Tech Support Guy, we highly recommend that you visit our Guide for New Members.

Intel 945gtp integrated sound will not work

Discussion in 'Hardware' started by FATBACK1980, Jan 30, 2007.

Thread Status:
Not open for further replies.
Advertisement
  1. FATBACK1980

    FATBACK1980 Thread Starter

    Joined:
    Jan 29, 2007
    Messages:
    7
    My soundcard just stop working one day, and since then, I have not been able to fix it....Please Help!!

    When installing intels driver i get this error message...

    Device object not present, restart system and run setup again....

    And when I try to install intel audio studio I get this error

    Intel Audio Studio Controller
    Error 453 Can't find DLL entry point sflInitSTCOM in IASDLL.DLL
     
  2. telegramsam

    telegramsam

    Joined:
    Jul 7, 2006
    Messages:
    1,085
    Uninstall any previous drivers, and if you have something like SigmaTel audio, uninstall it. Delete any downloads you have, run Ccleaner to delete bad registry entries, THEN try it again.

    I've had annoying problems with both of my D946GZIS boards and sound.
     
  3. FATBACK1980

    FATBACK1980 Thread Starter

    Joined:
    Jan 29, 2007
    Messages:
    7
    I just did all that to no avail...anything else i should try? Could the card have died?
     
  4. telegramsam

    telegramsam

    Joined:
    Jul 7, 2006
    Messages:
    1,085
    Look in your device manager and see if there are any other devices having conflicts or problems.
     
  5. FATBACK1980

    FATBACK1980 Thread Starter

    Joined:
    Jan 29, 2007
    Messages:
    7
    Device Manager is all good
     
  6. win2kpro

    win2kpro

    Joined:
    Jul 19, 2005
    Messages:
    11,670
    What operating system are you using, and what version is your BIOS?
     
  7. FATBACK1980

    FATBACK1980 Thread Starter

    Joined:
    Jan 29, 2007
    Messages:
    7
    I have winxp mce sp2 and my bios is the most uptodate from intels website. I just updated it the other day because I too thought that was the problem.
     
  8. telegramsam

    telegramsam

    Joined:
    Jul 7, 2006
    Messages:
    1,085
    Which driver are you loading? Do you have the disc from the mobo?
     
  9. FATBACK1980

    FATBACK1980 Thread Starter

    Joined:
    Jan 29, 2007
    Messages:
    7
  10. telegramsam

    telegramsam

    Joined:
    Jul 7, 2006
    Messages:
    1,085
    Try one of the STACGUI drivers. Some of those are for front panel headers and some are for rear panel outputs only. It may be that yours is trying to find hardware that isn't there.
     
  11. FATBACK1980

    FATBACK1980 Thread Starter

    Joined:
    Jan 29, 2007
    Messages:
    7
    Nope, it says the same error message...pergaps it is dead
     
  12. telegramsam

    telegramsam

    Joined:
    Jul 7, 2006
    Messages:
    1,085
    Here's a desperation measure that's worked on some occasions in the past. Run add hardware wizard and see if you can point it to C/Program Files/Intel, (or any other location that might be storing drivers) and see if it will pick one up and install it.

    Also check Windows and see if one of it's generic drivers will get it running.

    This is a couple of things to try before you pronounce it dead.
     
  13. FATBACK1980

    FATBACK1980 Thread Starter

    Joined:
    Jan 29, 2007
    Messages:
    7
    I tried the way you said, it installs it properly, but then it says that the device cannot start...so i guess it is dead...thanks for all the help though!!
     
  14. telegramsam

    telegramsam

    Joined:
    Jul 7, 2006
    Messages:
    1,085
    You're welcome.

    If you have PCI slots available, you can get cheap sound cards at Newegg that will probably be even better sounding than the onboard.

    Sorry it didn't work out for ya!
     
  15. Sponsor

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 733,556 other people just like you!

Loading...
Thread Status:
Not open for further replies.

Short URL to this thread: https://techguy.org/539598

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice