1. Computer problem? Tech Support Guy is completely free -- paid for by advertisers and donations. Click here to join today! If you're new to Tech Support Guy, we highly recommend that you visit our Guide for New Members.

Internet connection but can't get any browser to work

Discussion in 'Web & Email' started by Smiley028, Feb 4, 2009.

Thread Status:
Not open for further replies.
Advertisement
  1. Smiley028

    Smiley028 Thread Starter

    Joined:
    Feb 3, 2009
    Messages:
    5
    My system automatically updated to IE 8 a few days ago and now I can't get it to display any webpages. I have tried firefox and Safari and they will not display any webpages either. I tried to re-install all of them and they still don't work. I have windows xp pro, sp 2. I know there is an internet connection because msn messenger still works. I, unfortunately do not have a back-up disk for XP. What can I do if anything or do I just give up and take it to a shop. I can ping anything I want btw.
     
  2. karbo

    karbo Banned

    Joined:
    Sep 2, 2003
    Messages:
    2,239
    That's curious!?! Why would your system automatically update to IE 8? :confused:

    I'm running XP Pro SP3 with IE 7 and I've never been prompted by Windows Update to install IE 8.
     
  3. Babbinton

    Babbinton

    Joined:
    Feb 4, 2009
    Messages:
    8
    I use Firefox but latetly my system has been bugging me to do an automatic upgrade on IE. It doesn't do it automatically but if smiley reacted to the nag note, and clicked ok, then it uptaded.

    I'd suggest system restore and go to a restore point a few days or more before the update. That should reset the system and bypass whatever changes the new build of IE enacted.

    Just left click on the start button, then choose help. On the help screen if you look around there is a button for system restore.
     
  4. Smiley028

    Smiley028 Thread Starter

    Joined:
    Feb 3, 2009
    Messages:
    5
    I have tried going back to a month or so for my restore date and it won't complete the restore.
     
  5. Babbinton

    Babbinton

    Joined:
    Feb 4, 2009
    Messages:
    8
    Once upon a time I'd say just use your local library, and download IE or Firefox, but I'm not even sure you can download the whole program anymore, now they seem to be installers.

    But, you can go to a friend's or library computer to Softpedia.com and download Portable Firefox which is only 8mbs. Use a USB drive, you should be able to find a small one or to gig for under $8. Circuit City maybe...

    Then remove IE

    Start>Settings>Control Panel>Add or Remove Programs

    Start by removing the update. Reboot, if still problematic then remove Internet Explorer. Reboot, and start Portable Firefox from your USB port.

    Then using the portable Firefox with IE gone you (hopefully) can get back online. Then go reinstall either Firefox or IE.

    Might be worth a try...good luck.
     
  6. Smiley028

    Smiley028 Thread Starter

    Joined:
    Feb 3, 2009
    Messages:
    5
    I tried that already lol. Still the same result. Thx though
     
  7. redoak

    redoak Gone but never forgotten

    Joined:
    Jun 24, 2004
    Messages:
    6,782
    Look in the listing of installed programs in "Add/Remove" via the Control Panel. If IE 8 is there, remove it. This works for IE 7, so it might for 8. Your previous version of IE should reactivate.

    {redoak}
     
  8. Smiley028

    Smiley028 Thread Starter

    Joined:
    Feb 3, 2009
    Messages:
    5
    I have tried un-installing and re-installing. It still doesn't work. Doing fresh installs of any other browser also don't work
     
  9. redoak

    redoak Gone but never forgotten

    Joined:
    Jun 24, 2004
    Messages:
    6,782
    Why did you re-install? My thought was to work with another version of IE, and also see if the other browsers were ok. A trial and error approach.

    {redoak}
     
  10. Smiley028

    Smiley028 Thread Starter

    Joined:
    Feb 3, 2009
    Messages:
    5
    I have done all that. Different versions of different browsers and they still won't work. Thx for the input though.
     
  11. redoak

    redoak Gone but never forgotten

    Joined:
    Jun 24, 2004
    Messages:
    6,782
    You may have a malware infection. Click "Report" in the lower right and ask that your Thread be transferred to the "Security/HJT" Forum.

    {redoak}
     
  12. Sponsor

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 733,556 other people just like you!

Loading...
Thread Status:
Not open for further replies.

Short URL to this thread: https://techguy.org/797474