Internet connection issues if multiple programs are running

nefarious6453

Thread Starter
Joined
May 14, 2021
Messages
2
I have consistent download speeds of about 75mps and have no issues with my connection while I'm using a single program but most of the time when I open a new program that is using my internet connection, the original program either loses connection or new program has extreme difficulty in either obtaining a connection or sometimes it will move at a snails pace.
For example if I have a video game open and connected and I also try to open a web browser, most of the time browser will take longer than normal to connect and then eventually it will but the video game will become disconnected. Upon re-opening the game it will no reconnect until I close the web browser and wait roughly 2-5 minutes and then the game is able to reconnect. This happens with multiple different programs.
Any help or ideas would be greatly appreciated.
 
Joined
Mar 30, 2014
Messages
4,769
Download, install and run Speccy. Click File > Publish Snapshot > Yes > Copy to Clipboard and then paste in the URL you just copied into a Reply to this thread.
 

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 807,865 other people just like you!

Latest posts

Staff online

Top