internet doesn't load certain pages

Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

garvin122

Thread Starter
Joined
Apr 13, 2008
Messages
3
For some reason, my internet doesn't load certain pages. There is nothing wrong with my internet though because it does load fast for some websites and for other it just doesn't do anything regardless of how big the website is. I am using my other computer right now and everything works perfectly so it is not connection problem.

For example, www.google.com loads perfectly fine. When i do a search on google, it doesn't load. I have waited a hour and nothing happens. Sites like yahoo used to load perfectly fine but it doesn't load anymore. I have tried different internet browsers including internet explorer, firefox, and opera but the same thing happens.

If you guys want more information, ask away. Does anyone have a clue about what is happening here?

btw it looks like it is loading but nothing is actually happening.

Thanks in advance.
 
Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 807,865 other people just like you!

Latest posts

Staff online

Top