Internet Explorer 9 Browsing History Showing Local Files Only

Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

gigigirrl

Thread Starter
Joined
Apr 20, 2006
Messages
18
When using Internet Explorer 9 Browsing History Showing Local Files Only. I use Firefox, Chrome, and Opera also- none of those browsers exhibit the problem. I am seeing file history only - web file history. I would prefer to see web history only - no local file history.

Win 7 OP


Thank you.
 

Phantom010

Trusted Advisor
Joined
Mar 9, 2009
Messages
34,796
Internet Explorer is an intrinsic part of Windows. It's unavoidable.

However, you can try the following registry hack:

Press the Windows key + R to open a Run box.

Type regedit

Press Enter.

Browse to:

HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\comdlg32

If comdlg32 doesn't exist, create it:

Right-click Policies and select New > Key.

Name it comdlg32.

In the right pane, right-click an empty space and select New > DWORD Value.

Name it NoFileMru.

Next, double-click NoFileMru and give it an hexadecimal value of 1.

Close the registry editor.

You may need to restart your computer for changes to take effect.

Now, I've tried this on Windows XP and it works. Not entirely sure it'll be the same on Windows 7. But, it's worth a try. You can always delete what you did afterwards.


However, the easiest thing to do is to set IE9 to Delete browsing history on exit:

 

gigigirrl

Thread Starter
Joined
Apr 20, 2006
Messages
18
I am guessing my post was not clear. I do not want to clear my history. And I do not want to clear my most recently used list. When I click on the favorite icon in the upper right corner (with the Home Icon and settings icon) and the favorite window slides in...I choose the tab History. It shows me 3 weeks, two weeks and last week plus this weeks days. Under 3 weeks it shows urls of pages I have visited. Under two weeks it shows local computer files I have opened and urls of pages I have visted. Then under 1 week ago and the days of this week it just shows the local computer files I have opened. No internet browsing history. My settings are set to 20 days. I do not have it set to delete history - because I want to keep the internet browsing history. I want to have it track and be able to view for 20 days my internet browsing history.
 

gigigirrl

Thread Starter
Joined
Apr 20, 2006
Messages
18
I have also tried this solution:
Also check to make sure you don’t have the Use Windows Search for better results option enabled under AutoComplete. You can check this by:

· Open Internet Explorer

· Click Tools

· Click Internet Options

· Click the Content tab

· Under AutoComplete, click Settings

· Uncheck Use Windows Search for better results

· Click OK

· Click OK
That is the solution given to the same question as mine written like this:
Why does Internet Explorer show local files in History (Word, images, etc.) and how can I configure it to show only visited web sites?
 

Phantom010

Trusted Advisor
Joined
Mar 9, 2009
Messages
34,796
This should do what you're looking for. There's no other way I can think of. Browser history and MRU are closely related:

Internet Explorer is an intrinsic part of Windows. It's unavoidable.

However, you can try the following registry hack:

Press the Windows key + R to open a Run box.

Type regedit

Press Enter.

Browse to:

HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\comdlg32

If comdlg32 doesn't exist, create it:

Right-click Policies and select New > Key.

Name it comdlg32.

In the right pane, right-click an empty space and select New > DWORD Value.

Name it NoFileMru.

Next, double-click NoFileMru and give it an hexadecimal value of 1.

Close the registry editor.

You may need to restart your computer for changes to take effect.

Now, I've tried this on Windows XP and it works. Not entirely sure it'll be the same on Windows 7. But, it's worth a try. You can always delete what you did afterwards.
 
Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 807,865 other people just like you!

Latest posts

Members online

Top