Internet Explorer not working right on my PC

Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

sdjerry

Thread Starter
Joined
Aug 21, 2007
Messages
22
Ever since I've owned my current PC I've had a few different issues, but let's just start with the issues regarding IE for now. For some reason IE does not work right on this computer, and therefore Skype will not work right either since it relies on IE.

Basically flash player is not working on IE even though the latest version is installed and it's enabled, and I think javascript might be having some issues as well, it seems to be enabled from all the research I've been doing online to. Firefox is my default browser so I don't care about IE that much, but since it's affecting Skype I need to get it resolved.

I currently have IE 10 installed, I've had the same issues with IE 9 as well. No matter what I seem to try after reading different help forums the problems persist.

Specs for my PC are below, where do I begin?



OS Version: Microsoft Windows 7 Home Premium, Service Pack 1, 64 bit
Processor: Intel(R) Celeron(R) CPU G530 @ 2.40GHz, Intel64 Family 6 Model 42 Stepping 7
Processor Count: 2
RAM: 4040 Mb
Graphics Card: Intel(R) HD Graphics Family, 1796 Mb
Hard Drives: C: Total - 462502 MB, Free - 395486 MB;
Motherboard: Gateway, SX2855
Antivirus: Kaspersky Internet Security, Updated and Enabled
 
Joined
Sep 21, 2008
Messages
74
I too have been having problems with my IE. It stops working when it wants to. I'm using Win7 and IE10
which I just downloaded thinking it would help resolve the problem, but it didn't.
Dell Inspiron 546
6 gb DDR2 sd ram
ATI Radeon HD3200 Graphics
PC- ACPIx64 bit
Win 7-os
 
Joined
Jan 21, 2013
Messages
1
I have windows 7 ultimate with a 64 bit operating system. I use both firefox and tried updating to IE 10 in hopes of solving my log in problems. I have followed previous advice regarding this problem and none of it will work. Every site I use has to be logged in again as soon as I close the browser. This started happening a few weeks ago. everything is up to date and no adware/malware is present on my computer.

Thanks in advance for any suggestions or help with this problem.
 
Joined
Jan 29, 2013
Messages
15
With IE it has never been a good experience. In wonder why you are still interested in IE. Having said that, it has been a smooth experience on windows 8 with IE 10. Fingers crossed. I miss the Mozilla Add-ons but that's my way of appreciating windows 8 and MS. :)
 
Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 807,865 other people just like you!

Latest posts

Top