Internet keeps being choppy on all games.

Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

laxnoah

Thread Starter
Joined
Feb 3, 2017
Messages
13
For the last 2 days I have been experiencing problems while playing games. While playing I start rubberbanding at random times while playing. On my screen I will be somewhere, then after a second I will be sent back to my before position. I have tried restarting my router/modem, restarting my PC, and uninstalling and reinstalling my wireless adapter drivers. It happens while playing all types of games and has started to annoy me a lot. Thanks for any help.

Specs
Tech Support Guy System Info Utility version 1.0.0.4
OS Version: Microsoft Windows 8.1, 64 bit
Processor: AMD FX(tm)-8350 Eight-Core Processor, AMD64 Family 21 Model 2 Stepping 0
Processor Count: 8
RAM: 16332 Mb
Graphics Card: Radeon (TM) RX 480 Graphics, -1 Mb
Hard Drives: C: 931 GB (37 GB Free);
Motherboard: MSI, 970 GAMING (MS-7693)
Antivirus: Windows Defender, Enabled and Updated
 

Couriant

James
Trusted Advisor
Spam Fighter
Joined
Mar 26, 2002
Messages
36,006
To add to this, if at all possible depending on your set up, go direct to your modem (if it's separate to the router) and see if you get the same results.
 
Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 807,865 other people just like you!

Latest posts

Members online

Top