1. Computer problem? Tech Support Guy is completely free -- paid for by advertisers and donations. Click here to join today! If you're new to Tech Support Guy, we highly recommend that you visit our Guide for New Members.

Internet ONLY works with IE

Discussion in 'Networking' started by TomIrony, Nov 23, 2011.

Thread Status:
Not open for further replies.
  1. TomIrony

    TomIrony Thread Starter

    Joined:
    Nov 23, 2011
    Messages:
    2
    My problem:

    For reasons unknown, the only application that properly connects to the internet is Internet Explorer. Firefox, Chrome, Steam and other applications refuse to acknowledge the connection.

    I've called my ISP and there doesn't seem to be a problem on their end (and I'm using the Internet now). I've tried switching from a cable connection to wireless with no change. I've tried activating and de-activating (and uninstalling at one point) my anti-virus, updating the network card drivers, and reverting to a previous back-up, all to no avail.

    My network settings detect no problem with the connection itself, so there seems to be something on my end blocking everything but IE. It's very strange. Any help to get this unblocked would be very appreciated.

    My system:

    OS Version: Microsoft® Windows Vista™ Home Premium, Service Pack 1, 64 bit
    Processor: Intel(R) Core(TM)2 Duo CPU P8700 @ 2.53GHz, Intel64 Family 6 Model 23 Stepping 10
    Processor Count: 2
    RAM: 6142 Mb
    Graphics Card: NVIDIA GeForce GTX 260M, 1024 Mb
    Hard Drives: C: Total - 238469 MB, Free - 16293 MB; D: Total - 229466 MB, Free - 184606 MB;
    Motherboard: ASUSTeK Computer INC., G71GX
    Antivirus: Lavasoft Ad-Watch Live! Anti-Virus, Disabled
     
  2. TomIrony

    TomIrony Thread Starter

    Joined:
    Nov 23, 2011
    Messages:
    2
    Okay, I fixed the problem!

    Here's the solution I used:

    1. Click Start, and in the search bar at bottom typed: "cmd".
    2. Right-clicked on CMD and clicked "Run as administrator".
    3. In the command window, typed the following and pressed Enter after each line:

    • netsh winsock reset
    • netsh int reset
    • ipconfig /flushdns
    4. Restarted my computer.

    The problem was fixed upon restart.
     
As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 733,556 other people just like you!

Loading...
Thread Status:
Not open for further replies.

Short URL to this thread: https://techguy.org/1028227

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice