Internet speed issue

Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

cladv12

Thread Starter
Joined
Nov 6, 2018
Messages
3
Have two Dell PCs both hard wired the same to modem/router. Older one gives me DL speed of 85 and UL of 35. Newer one gives 33 and 36 so UL is higher. Used to be way higher closer to 100

Running Windows 10 on both and all updates have been installed. Talked to Cable provider and they say all is well from their end.

Ran Defender and free malwarebytes and both were clean. Also ran free crapcleaner

Have no idea so please help.

Thanks.
 

plodr

Liz
Joined
Jun 27, 2014
Messages
23,730
Turn off the PC with the download speed of 85Mbps.
Test the other PC. Does the download stay the same or increase?
Change the port that the slower computer is in. Does it change anything?
Swap the ethernet wires between the two computers. Does that change anything?
(I do this to see if a port on a router is bad or possibly a cable is going bad).

Also, checking to see what channels each computer is using. Are they the same or different?

Open Device Manager. What network adapter is on each computer? We'll call one computer F for fast and the other S for slow. What are the dates of the drivers on each?
 

cladv12

Thread Starter
Joined
Nov 6, 2018
Messages
3
Cable company claims we should get 100 speed

to recap, here is what I have done:

rebooted modem and router

cleaned out cookies and temp files using windows and crapcleaner and browsers

switched the output cables from the router to different ports; changed cable from router to problem PC

just ran speed tests on both PCs and upstairs one is 91/35 while main floor one is 44/34. better but not the same which based on how all the cables are set up should not be different

Note that this did not happen as a result of my doing anything with the components or cables, everything is the same as it was before when both PCs ran 90+/35 So, seems to me that the router and modem are somehow able to deliver very fast speed to one PC but not to the other

tried safe mode reboot with networking

did not see anything diff on screen from reg mode boot

ran speed test and got 115/6 on the 'slow' PC
 

plodr

Liz
Joined
Jun 27, 2014
Messages
23,730
upstairs one is 91/35 while main floor one is 44/34
Which one is closer to the router?

How long is the cable connecting the computer farther away from the router?
 

cladv12

Thread Starter
Joined
Nov 6, 2018
Messages
3
the slow PC is right next to the router; Ethernet cable maybe 3' max

the other cable may be either 75 or 100' but that is the PC that has the fast speed
 
Joined
Sep 21, 2007
Messages
13,729
Open task manager > app history. This will show you how much network each app has used. If you want, you can un-install suspicious ones
 
Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 807,865 other people just like you!

Latest posts

Top