Solved Internet speeds suddenly really bad on main computer

Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

Dkmainman

Thread Starter
Joined
Jul 29, 2021
Messages
2
For the longest time, my computer had great internet speeds, getting the 200/20 we were paying for, often even better. 2 days ago, however, my main computer dropped speeds and hasn't been able to go anywhere near the speeds it was at, often getting less than a megabyte of download and upload speeds, with it occasionally going up to 5 mbps if I'm lucky. The part that worries me, however, is that my old laptop, phone, and all the other devices my family is using are all getting those fast speeds, so the only computer that is struggling is my current computer. I ran a malware scan, but it came up negative, so now I have no idea what to do, because this tech stuff is not my forte. The only thing I can think of that might have affected things is that there was a BIOS update earlier in the day when the internet stopped working, but other than that I haven't downloaded anything onto it. What should I do about this?

I don't know what specs I should write down either, so just ask and you will receive. I will say that I am using Windows 10, however.
 

JohnWill

Retired Moderator
Joined
Oct 19, 2002
Messages
106,724
Check your cable if it's a wired connection. I just recently had a broken wire in the cable and that dropped me from gigabit Ethernet to 100mbit,
 

Dkmainman

Thread Starter
Joined
Jul 29, 2021
Messages
2
While checking the cables I realized the device was obstructed, and when I fixed that it worked again. Technology is weird, but at least it’s working again.
 

plodr

Liz
Joined
Jun 27, 2014
Messages
25,151
tofag44931, Welcome to TSG. No need to post in a thread that has been solved as of yesterday. You'll find there are more than enough unsolved threads that you can offer support for.
 
Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 807,865 other people just like you!

Latest posts

Members online

Top