Invalid VxD call from acpi

Status
This thread has been Locked and is not open to further replies. The original thread starter may use the Report button to request it be reopened but anyone else with a similar issue should start a New Thread. Watch our Welcome Guide to learn how to use this site.

Robert . O

Thread Starter
Joined
Jan 19, 2001
Messages
63
I have been getting this error message for a little bit now and was wondering how to fix it. What it seeems to be doing is preventing my pc from shutting down all the way. I get " It is now safe to turn of your computer."


the erreor message is
Invalid vxd from dynamic link call from acpi ( 05) 0000058 to device 0026, service 8019

your windows config is invalid. Run the windows setup program again to correct this problem.

I have check microsoft and there was nothing there to help me with acpi, there are no conflicts in device mananger, and there is no problem working with windows once i am on with the exception of shutting down

It's a built pc with windows 98 (1st ed)
156 meg o ram
3 gig maxtor & a 604 meg seagate hdd
750 amd duron cpu

although I am not 100 % sure I have installed a lyncsys nic and think that the problem may have started after that.

any help would be thankful
Bob
 
Joined
Sep 10, 2001
Messages
3,178
Hi,

Try going into your Device Manager, then expanding System Devices, and then double-clicking Advanced Power Management. See if there's an option in there to disable. Quite often, this can cause problems with the system not shutting down properly.

Good Luck
 

Robert . O

Thread Starter
Joined
Jan 19, 2001
Messages
63
I have it turned off in bios, but it still doesn't sgut down all the way.
If I was to turn off acpi in bios, what would happen?
 
Joined
Dec 9, 2000
Messages
45,855
Usually APM must be enabled in the BIOS for the system to shut all the way down automatically.

I'm not sure what the consequences of disabling ACPI are, but many do it to resolve conflicts and I haven't heard of any serious issues resulting. Maybe the loss of some power management functions, but APM disabled also affects that.
 
Joined
Sep 10, 2001
Messages
3,178
Hi,

In response to your comment at the bottom of your first post, have you tried disabling, or even physically removing the linksys card? It would be one way to determine whether or not it is causing the problem.
 

Robert . O

Thread Starter
Joined
Jan 19, 2001
Messages
63
I haven't taken the network card out of the pc, but did uninstall and reinstall the drivers. That didn't work

As for turning off acpi in bios, when I did that windows was ready to detect everything in my pc again so I stopped and turned it back on. BTW My cd drive was not listed among other things when I disabled acpi in bios

I am still at a loss
 
Joined
Sep 10, 2001
Messages
3,178
Hi, :)

What I meant in my last post was, can you disable the network card, then reboot your system, then try to shutdown. Not uninstall, restart, then re-install. Simply removing, then re-adding your network card, won't help us determine if its causing the problem.
Also, in my first post, I didn't mention disabling ACPI in the BIOS. I said that there should be something in Device Manager in Windows named APM or ACPI, that you can disable. Look for any Power Management entries in Device Manager, and see if they have a check-box in their properties that you can "disable in this hardware profile".
 

Robert . O

Thread Starter
Joined
Jan 19, 2001
Messages
63
I disabled the network card in device manager and rebooted but had the same problem when shutting down.
It said that it is now safe to turn of pc.

I also looked in the system devices in device manager and looked at the properties of each line that had acpi mentioned in it (there was no mention of apm) there was no disable in this hardware profile.

I am guessing that it is not the network card? something else going goofy?

thanks for your help
Bob
 
Joined
Dec 9, 2000
Messages
45,855
Is APM currently enabled in the BIOS? And what happens if it is?

Stopping on the "it is now safe to turn off..." screen is characteristic of APM being disabled.
 
Joined
Dec 9, 2000
Messages
45,855
It does seem to describe your problem. But you will have to contact Microsoft Support for the "fix"

Is fast shutdown enabled in msconfig > advanced? If you downloaded the "shutdown supplement" it usually will not be.

To troubleshoot this at all you will need to leave APM enabled in the BIOS, as it will normally stop on that screen with it disabled.

You could also check to see if the "Fast Reboot" key is set to "1" in the registry:

http://support.microsoft.com/support/kb/articles/Q187/6/07.ASP

Also with APM enabled in the BIOS, you can try removing it through the Device Manager and let Windows redetect and reinstall it. You may need your Windows CD or to point to the c:\windows\options\cabs directory if prompted for a disk
 

Robert . O

Thread Starter
Joined
Jan 19, 2001
Messages
63
You could also check to see if the "Fast Reboot" key is set to "1" in the registry:




were at in the registry would I find that...

Is fast shutdown enabled in msconfig > advanced



yes it is enabled


also in device manager there is no mention of " APM"
 
Joined
Dec 9, 2000
Messages
45,855
Status
This thread has been Locked and is not open to further replies. The original thread starter may use the Report button to request it be reopened but anyone else with a similar issue should start a New Thread. Watch our Welcome Guide to learn how to use this site.

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 807,865 other people just like you!

Latest posts

Members online

Top