1. Computer problem? Tech Support Guy is completely free -- paid for by advertisers and donations. Click here to join today! If you're new to Tech Support Guy, we highly recommend that you visit our Guide for New Members.

Iomega Portable USB 2.0 Hard Drive

Discussion in 'Hardware' started by mylastreckoning, Sep 21, 2009.

Thread Status:
Not open for further replies.
Advertisement
  1. mylastreckoning

    mylastreckoning Thread Starter

    Joined:
    Dec 3, 2007
    Messages:
    15
    ok the story... i use my external for alot mainly music and gaming back up for my PS3 i used it for a couple years now never had a problem with it till just resently ill plug it in and altho the LED lights up and does its usual thing nothing happens on my PC or PS3 they dont read it no auto start no icon in "MY COMPUTER" to manually use it and nothing on my PS3 whats my problem??? plz help i have alot of family photos and sentimental files that took time and effort in revamping uploading typing etc my external "IOmega PHDD" was ment to be back up but when i didnt have a PC it was my main source of memory etc it has 160G on it i used about 120G of its memory thats y it is vital to get it to work and alot of the photos r no longer with this family PLEASE HELP!!!!
     
  2. Alex Ethridge

    Alex Ethridge

    Joined:
    Apr 10, 2000
    Messages:
    9,049
    It's not backup if there's only one copy, regardless.

    The first thing to determine is whether it is the enclosure that has gone bad or the disk inside. Disassemble the enclosure, remove the disk and connect it internally to another desktop computer. See if it comes up on it.

    You may have to go to the disk manufacturer's web site for proper jumper settings.
     
  3. mylastreckoning

    mylastreckoning Thread Starter

    Joined:
    Dec 3, 2007
    Messages:
    15
    well thnx for the help ill try that in the morning
    btw i had the original copies on my PC but when i sold it i deleted shredded and formated every thing by doing that i backed up every thing to my external thus is y i say its my back up its habit forming lol after i fix this im so goin to have to buy a couple more xdrives so that way i can have a copy of all the copies i had made copies of lol
     
  4. mylastreckoning

    mylastreckoning Thread Starter

    Joined:
    Dec 3, 2007
    Messages:
    15
    ok its making a wierd noise its not clicking per say more of a wierd morse code mechanical high pitched buzz sound its hard toreally discribe it... then after awhile it will stop i cant remember if it made that sound prior to my problem or not
     
As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 733,556 other people just like you!

Loading...
Thread Status:
Not open for further replies.

Short URL to this thread: https://techguy.org/862549

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice