iTunes messed up my album artwork!

Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

YerOldPoison

Thread Starter
Joined
Jul 2, 2010
Messages
51
Hey guys! I am here once again. This time with a totally different problem than my previous one.

I decided to get my songs (2000+ of them - they're on my external HDD) their names right/fixed, artist name, album, album artwork etc. It was all fine until I finished. I got it all sorted and tip top. At least I thought that until the next day, when I opened my iTunes again. The names, artists, albums... remained, but album artwork was a disaster! One single picture was on about 3/4 of my songs, while that 1/4 or so, remained untouched and just the way I left them the day before. I can't find it ANYWHERE on my computer. I've searched all the folders for at least 10 times (Image's name should be "folder.jpg"; at least that's what it says in MediaMonkey - where I checked if it was the same there. Well it was and it said that it's located in the same folder, as my music and named "folder.jpg") ! I don't get it!! I want to get rid of that picture now, but it's already somehow clipped to my songs and and even if I select "Delete album artwork" in iTunes, that picture still remains and I have to erase it step by step, song after a song in that Info tab or w/e. And even after I've done this and it all seemed fine and decided to call it a day and the next day it was the same as it was the day before!! HOW can I erase that picture and is there any way to prevent iTunes (or w/e is causing this to occur) doing this over and over again!?

I am desperate, I've been having a REALLY hard time accepting that all my time was wasted (I've been dealing with this for at least 2 months)!

Thank you in advance,
YerOldPoison

PS Everything I've changed was through iTunes; checked in Media Monkey if the same problem persists there
 

YerOldPoison

Thread Starter
Joined
Jul 2, 2010
Messages
51
The problem persists... The image is clipped onto the music files. It stays even if I move it to the damn Mt. Everest!
 
Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 807,865 other people just like you!

Latest posts

Staff online

Top