1. Computer problem? Tech Support Guy is completely free -- paid for by advertisers and donations. Click here to join today! If you're new to Tech Support Guy, we highly recommend that you visit our Guide for New Members.

JavaScript links do not work

Discussion in 'All Other Software' started by timbit, Nov 9, 2003.

Thread Status:
Not open for further replies.
Advertisement
  1. timbit

    timbit Thread Starter

    Joined:
    Nov 9, 2003
    Messages:
    36
    Hi. I've been screaming at my computer for the last month and a half or so, because it has this tendency to stop working with JavaScript links. When it first started, I tried going to Microsoft's website for help (that was bright :rolleyes: ) but half of the links I needed to get to the support area were javascript. I tried installing a whole binch of crap from Sun Java's site. I scanned my system for adware, spyware, and viruses. Nothing worked. Finally, i decided to do sytem restore, but for some reason it was corrupted and the screen wouldn't show up for it. So I wiped my hard drive and reinstalled Windows. Three times. That sucked bad. Almost drove me to linux, except that I like playing games. After the fourth install, things seemed to be normal, but two days ago, it started up again. Since I didn't want to play the reinstall game again, I decided to look for help. If anybody can help me, I'd appreciate it. I use SlimBrowser for my browser, but it isn't working in IE either. Oh yeah, I have Norton now, but I turned off the Java / Applet security stuff, and it still doesn't work. I also downloaded Windows Script 5.6 (read it in another thread) but that didn't help either. I'd really appreciate any help anybody can give. Thanks.
     
  2. Elvandil

    Elvandil

    Joined:
    Aug 1, 2003
    Messages:
    51,988
    Go to Start > Run and try re-registering some files by running these at the command line:

    regsvr32 msscript.ocx
    regsvr32 dispex.dll
    regsvr32 vbscript.dll
    regsvr32 scrrun.dll
    regsvr32 imm32.dll
    regsvr32 version.dll
    regsvr32 dmscript.dll
    regsvr32 jscript.dll
    regsvr32 scripto.dll
    regsvr32 scriptpw.dll

    ---------------------------------------------------
    Then check if Open for file-type .js is properly associated:

    1.) Open Control Panel > Folder Options > File Types.

    2.) Find .js extension and click on "Advanced".

    3.) Click on Open and then the Edit button.

    4.) Check and make sure the Application used to perform action field has this: C:\WINDOWS\System32\WScript.exe "%1" %*
    (modifying, of course, if C: is not your system drive and Windows is not your installation directory).

    5.) Click OK until you're out of there.

    ---------------------------------------------------
    Then, be sure wscript.exe is your default scripting engine:

    1.) Go to Start > Run and type:
    cmd

    2.) Click OK.

    3.) At the command prompt, type:
    cscript //H:WScript

    (You should receive confirmation that wscript.exe is now your default scripting engine).

    4.) Type: exit
     
  3. Rollin' Rog

    Rollin' Rog

    Joined:
    Dec 9, 2000
    Messages:
    45,855
    Be aware that Java applets and javascript are two different things, so nothing at the Sun site would have any relevance. If you installed wscript 5.6 and still cannot get javascript to work, something is blocking it.

    Are these "pop-up" windows controlled by javascript that are giving you problems? If so, do you have a pop-up or ad blocker installed? Norton's firewall may do this as well.

    Let's have a look at a HijackThis Scanlog

    http://www.tomcoyote.org/hjt/

    If you go to this site, do you see the words


    YES!...IF YOU CAN READ THIS, YOU ARE JavaScript ENABLED!

    http://www.bodo.com/javame.htm
     
  4. timbit

    timbit Thread Starter

    Joined:
    Nov 9, 2003
    Messages:
    36
    Ok, I ran those regsvr 32 things, and they all worked except for three of them. When I ran regsvr32 imm32.dll , I got an error message saying "imm32.dll was loaded, but the DllRegisterServer entry point was not found. This file cannot be registered." I got the same message when I tried regsvr32 version.dll. When I tried to load regsvr32 scriptpw.dll, I got a message that said "Load Library ("scriptpw.dll") failed - the specified module could not be found."

    The File Type was set up properly, and I did the cmd script thing.

    The "pop-up windows" are not the problem, it is the links. So anything that uses JavaScript for a link (as opposed to a url) I can't access.

    This is the HijackThis Scanlog. (Doesn't make any sense to me, but that's why I'm here :( )
    Logfile of HijackThis v1.97.3
    Scan saved at 10:50:18 AM, on 11/9/2003
    Platform: Windows XP SP1 (WinNT 5.01.2600)
    MSIE: Internet Explorer v6.00 SP1 (6.00.2800.1106)

    Running processes:
    C:\WINDOWS\System32\smss.exe
    C:\WINDOWS\system32\winlogon.exe
    C:\WINDOWS\system32\services.exe
    C:\WINDOWS\system32\lsass.exe
    C:\WINDOWS\system32\svchost.exe
    C:\WINDOWS\System32\svchost.exe
    C:\Program Files\Common Files\Symantec Shared\ccSetMgr.exe
    C:\Program Files\Common Files\Symantec Shared\ccEvtMgr.exe
    C:\WINDOWS\system32\spoolsv.exe
    C:\WINDOWS\Explorer.EXE
    C:\Program Files\Common Files\Real\Update_OB\realsched.exe
    C:\Program Files\QuickTime\qttask.exe
    C:\Program Files\Java\j2re1.4.2_02\bin\jusched.exe
    C:\Program Files\Messenger Plus! 2\MsgPlus.exe
    C:\Program Files\Common Files\Symantec Shared\ccApp.exe
    C:\Program Files\Common Files\Symantec Shared\ccProxy.exe
    C:\Program Files\Norton Internet Security\Norton AntiVirus\navapsvc.exe
    C:\WINDOWS\System32\nvsvc32.exe
    C:\Program Files\Norton Internet Security\Norton AntiVirus\SAVScan.exe
    C:\Program Files\Common Files\Symantec Shared\SNDSrvc.exe
    C:\Program Files\Common Files\Symantec Shared\CCPD-LC\symlcsvc.exe
    C:\Program Files\MSN Messenger\msnmsgr.exe
    C:\Program Files\Internet Explorer\iexplore.exe
    C:\Program Files\InstantGet\InstantGet.exe
    C:\downloads\soft\hijackthis_temp\HijackThis.exe

    R0 - HKCU\Software\Microsoft\Internet Explorer\Main,Start Page = http://msn.com/
    O2 - BHO: (no name) - {06849E9F-C8D7-4D59-B87D-784B7D6BE0B3} - C:\Program Files\Adobe\Acrobat 6.0\Reader\ActiveX\AcroIEHelper.dll
    O2 - BHO: InstantGet IECatcher - {569E7719-1A11-415E-9206-AC1860FB8BFF} - C:\Program Files\InstantGet\IGCatcher.dll
    O2 - BHO: Web assistant - {9ECB9560-04F9-4bbc-943D-298DDF1699E1} - C:\Program Files\Common Files\Symantec Shared\AdBlocking\NISShExt.dll
    O2 - BHO: NAV Helper - {BDF3E430-B101-42AD-A544-FADC6B084872} - C:\Program Files\Norton Internet Security\Norton AntiVirus\NavShExt.dll
    O3 - Toolbar: InstantGet Bar - {98C92840-EB1C-40bd-B6A5-395EC9CD6510} - C:\Program Files\InstantGet\IGIEBar.dll
    O3 - Toolbar: &Radio - {8E718888-423F-11D2-876E-00A0C9082467} - C:\WINDOWS\System32\msdxm.ocx
    O3 - Toolbar: Web assistant - {0B53EAC3-8D69-4b9e-9B19-A37C9A5676A7} - C:\Program Files\Common Files\Symantec Shared\AdBlocking\NISShExt.dll
    O3 - Toolbar: Norton AntiVirus - {42CDD1BF-3FFB-4238-8AD1-7859DF00B1D6} - C:\Program Files\Norton Internet Security\Norton AntiVirus\NavShExt.dll
    O4 - HKLM\..\Run: [WinampAgent] "C:\Program Files\Winamp3\winampa.exe"
    O4 - HKLM\..\Run: [TkBellExe] "C:\Program Files\Common Files\Real\Update_OB\realsched.exe" -osboot
    O4 - HKLM\..\Run: [QuickTime Task] "C:\Program Files\QuickTime\qttask.exe" -atboottime
    O4 - HKLM\..\Run: [nwiz] nwiz.exe /install
    O4 - HKLM\..\Run: [NvCplDaemon] RUNDLL32.EXE C:\WINDOWS\System32\NvCpl.dll,NvStartup
    O4 - HKLM\..\Run: [NeroCheck] C:\WINDOWS\System32\NeroCheck.exe
    O4 - HKLM\..\Run: [SunJavaUpdateSched] C:\Program Files\Java\j2re1.4.2_02\bin\jusched.exe
    O4 - HKLM\..\Run: [QuickFinder Scheduler] "C:\Program Files\WordPerfect Office 11\Programs\QFSCHD110.EXE"
    O4 - HKLM\..\Run: [WordPerfect Office 1115] C:\Program Files\Common Files\Corel\Registration\EN\Registration.exe /title="WordPerfect Office 11" /date=112303 serial=WP11WED-0229627-FNT
    O4 - HKLM\..\Run: [MessengerPlus2] "C:\Program Files\Messenger Plus! 2\MsgPlus.exe"
    O4 - HKLM\..\Run: [Explore] C:\WINDOWS\system32\Explore.exe
    O4 - HKLM\..\Run: [ccApp] "C:\Program Files\Common Files\Symantec Shared\ccApp.exe"
    O4 - HKLM\..\Run: [URLLSTCK.exe] C:\Program Files\Norton Internet Security\UrlLstCk.exe
    O4 - HKCU\..\Run: [MessengerPlus2] "C:\Program Files\Messenger Plus! 2\MsgPlus.exe" /WinStart
    O4 - HKCU\..\Run: [msnmsgr] "C:\Program Files\MSN Messenger\msnmsgr.exe" /background
    O8 - Extra context menu item: &Download with InstantGet - res://C:\Program Files\InstantGet\IGCatcher.dll/IGLink.htm
    O8 - Extra context menu item: Download &all with InstantGet - res://C:\Program Files\InstantGet\IGCatcher.dll/IGAll.htm
    O8 - Extra context menu item: Open using &Advanced JPEG Compressor - C:\Program Files\Advanced JPEG Compressor\ajcieex.htm
    O8 - Extra context menu item: Set as &Display Picture - C:\IEDP\IEDP.htm
    O9 - Extra 'Tools' menuitem: Sun Java Console (HKLM)
    O9 - Extra button: Run InstantGet (HKLM)
    O9 - Extra 'Tools' menuitem: &InstantGet (HKLM)
    O9 - Extra button: Related (HKLM)
    O9 - Extra 'Tools' menuitem: Show &Related Links (HKLM)
    O16 - DPF: {00B71CFB-6864-4346-A978-C0A14556272C} (Checkers Class) - http://messenger.zone.msn.com/binary/msgrchkr.cab
    O16 - DPF: {02BF25D5-8C17-4B23-BC80-D3488ABDDC6B} (QuickTime Object) - http://www.apple.com/qtactivex/qtplugin.cab
    O16 - DPF: {166B1BCA-3F9C-11CF-8075-444553540000} (Shockwave ActiveX Control) - http://download.macromedia.com/pub/shockwave/cabs/director/swdir.cab
    O16 - DPF: {19E28AFC-EAE3-4CE5-AC83-2407B42F57C9} (MSSecurityAdvisor Class) - http://download.microsoft.com/downl...-a3de-373c3e5552fc/msSecAdv.cab?1068015058718
    O16 - DPF: {2917297F-F02B-4B9D-81DF-494B6333150B} (Minesweeper Flags Class) - http://messenger.zone.msn.com/binary/MineSweeper.cab
    O16 - DPF: {56336BCB-3D8A-11D6-A00B-0050DA18DE71} (RdxIE Class) - http://207.188.7.150/09ad6f3bd6e85a54b804/netzip/RdxIE601.cab
    O16 - DPF: {8E0D4DE5-3180-4024-A327-4DFAD1796A8D} (MessengerStatsClient Class) - http://messenger.zone.msn.com/binary/MessengerStatsClient.cab
    O16 - DPF: {9F1C11AA-197B-4942-BA54-47A8489BB47F} (Update Class) - http://v4.windowsupdate.microsoft.com/CAB/x86/unicode/iuctl.CAB?37900.7968981481
    O16 - DPF: {D27CDB6E-AE6D-11CF-96B8-444553540000} (Shockwave Flash Object) - http://active.macromedia.com/flash2/cabs/swflash.cab
    O16 - DPF: {EF791A6B-FC12-4C68-99EF-FB9E207A39E6} (McFreeScan Class) - http://download.mcafee.com/molbin/iss-loc/vso/en-us/tools/mcfscan/1,5,0,4302/mcfscan.cab
    O16 - DPF: {F04A8AE2-A59D-11D2-8792-00C04F8EF29D} (Hotmail Attachments Control) - http://by10fd.bay10.hotmail.msn.com/activex/HMAtchmt.ocx

    Oh yeah, I visited the Java test site or whatever that was, and I could see everything.

    Thanks again guys, this is driving me nuts, and i really appreciate your help.
     
  5. Elvandil

    Elvandil

    Joined:
    Aug 1, 2003
    Messages:
    51,988
    I didn't check to see if all those libraries were self-registering, so your results may be normal.

    Try this javascript test:

    http://gateway.lib.ohio-state.edu/tutor/jscript.html

    Have you enabled scripting in NAV? It is disabled by default, I think.

    Security settings for IE at default?

    Any ad-blockers or anything that may be acting as a popup blocker? Try shutting down running programs (particularly in the tray) one at a time and trying a js link again.
     
  6. timbit

    timbit Thread Starter

    Joined:
    Nov 9, 2003
    Messages:
    36
    Yes, the pop ups work. I don't ever have a problem with pop ups. It's only when there is a link that was written in Javascript. When I "mouse over" the link, at the bottom of the browser there is a little bar that either has a url address or a javascript thing. The link will not work if it is in Javascript. I can click forever, and all that will happen is that I will hear a click. Nothing else happens. I suppose I could try reinstalling IE, but I really don't know if that will work either. It's just frustrating when you go to a site and then can't get around because half of the links won't work for you. Oh well, I think my computer hates me. Maybe I should just throw it out the window... :mad: teach it to tick me off...

    Again, I really do appreciate the help
     
  7. flytape8490

    flytape8490

    Joined:
    Oct 7, 2003
    Messages:
    703
    Ummm... can anyone look at mine plz?
     
  8. timbit

    timbit Thread Starter

    Joined:
    Nov 9, 2003
    Messages:
    36
    Ok, now I feel like an idiot. As it turns out, I can open Javascript links, just not all of them. My guess is that it is the sites' fault (although more than one site experiencing the same problem at once is kinda weird). Thanks a ton for the support, sorry for wasting everyone's time.
     
  9. Rollin' Rog

    Rollin' Rog

    Joined:
    Dec 9, 2000
    Messages:
    45,855
    I don't know if this is the problem with the javascript links, we'll come back to that.

    But you have a trojan entry showing in the HijackThis log:

    O4 - HKLM\..\Run: [Explore] C:\WINDOWS\system32\Explore.exe

    I don't know whether the file actually exists and is loading since I don't see it as a running process.

    Check the c:\windows\system32 folder for explore.exe (make sure show hidden files is checked in Folder Options > view).

    Use HijackThis to check and "fix" the registry entry. Delete the actual file. If you have a problem deleting it, reboot in Safe Mode to do it. (tap f8 a few times early in the boot process to get the Boot Menu with Safe Mode, or run msconfig and check /safeboot under the Boot.ini tab)

    To get back to the javascript problem, try a "clean boot". Run msconfig and uncheck the option to load the Startup Items on the general page. Reboot and see if you still have the problem. If not, it is caused by something there. My bet would be Norton.

    Might be related to this process in Norton:

    O3 - Toolbar: Web assistant - {0B53EAC3-8D69-4b9e-9B19-A37C9A5676A7} - C:\Program Files\Common Files\Symantec Shared\AdBlocking\NISShExt.dll

    If you still want to pursue the java link problem, point us to the locations where you are experiencing the difficulty.
     
  10. timbit

    timbit Thread Starter

    Joined:
    Nov 9, 2003
    Messages:
    36
    Wow! Thanks a ton guys. That did it. I searched high and low for the "explore.exe" program, but, so far as I can tell, it doesn't exist on my computer. I did fix the registry. And when I turned off the startup things, the javascript problem fixed itself, so I guess I'll do a little work with norton and see if that doesn't clear up totally. Again, thanks for the help. I don't know where my computer would be without it - wait, yes I do. It would be at the bottom of a cliff somewhere. Thank You All!!!
     
  11. Rollin' Rog

    Rollin' Rog

    Joined:
    Dec 9, 2000
    Messages:
    45,855
  12. Sponsor

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 733,556 other people just like you!

Loading...
Thread Status:
Not open for further replies.

Short URL to this thread: https://techguy.org/178063

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice