1. Computer problem? Tech Support Guy is completely free -- paid for by advertisers and donations. Click here to join today! If you're new to Tech Support Guy, we highly recommend that you visit our Guide for New Members.

Keep Ethernet USB Adapter On While Laptop Sleep or Hibernate

Discussion in 'Networking' started by techaurelius, Dec 4, 2019 at 4:32 AM.

Advertisement
  1. techaurelius

    techaurelius Thread Starter

    Joined:
    Wednesday
    Messages:
    6
    I tried to remotely wake up my Windows 10 laptop by connecting an Ethernet cable from my Raspberry Pi to an Amazon Basics Gigabit Ethernet USB Adapter, which I plugged into the USB 3.0 port of my laptop that I'm trying to remotely wake up. The lights on the Adapter turned on while my laptop was on, but whenever I hibernate or sleep my laptop, the lights turn off on the Ethernet adapter.

    On the laptop I'm trying to remotely wake up, I have tried going into BIOS to enable USB charging in the off state and disabling USB selective suspend setting and "Allow the computer to turn off this device to save power" in power management for the Ethernet Adapter and USB Root Hub (USB 3.0), but this still happens. On the other hand, I was able to charge my phone when plugging it into the same USB port of my laptop that I'm trying to wake up while the laptop was on hibernate or sleep.

    When I turned the laptop back on manually, I ran powercfg /DEVICEQUERY wake_armed in my command prompt, and my network adapter associated with the Ethernet USB adapter appeared on the list, so I'm still trying to figure out why I couldn't remotely wake my laptop. I have also tried this on a Windows 7 laptop where I enabled Wake On LAN in the BIOS, but the same thing happened: the lights turned off on the Ethernet USB adapter and I can't remotely wake the laptop.

    If anyone can help, I'd greatly appreciate it. If I can get the lights on the Ethernet USB adapter to stay on while the laptop is off, I can use the Raspberry Pi to remotely wake up my laptop.
     
  2. Couriant

    Couriant Trusted Advisor

    Joined:
    Mar 26, 2002
    Messages:
    34,122
    First Name:
    James
    To confirm, you checke the Allow this device to wake up the computer?

    upload_2019-12-4_9-43-12.png

    Note, this image is for an on-board Ethernet card, but it should still be the same for the USB-Ethernet, unless the driver for this device does not support it.
     
  3. techaurelius

    techaurelius Thread Starter

    Joined:
    Wednesday
    Messages:
    6
    Hi Couriant, yes. For the Network Adapter associated with my Ethernet USB Adapter, I disabled "Allow the computer to turn off this device to save power" and enabled both "Allow this device to wake the computer" and "Only allow a magic packet to wake the computer". I also notice that sometimes randomly when I check, what I set changes back to before what I set it as when I open Device Manager and go to Power Management for this device. I tried this on my Windows 7 and Windows 10 laptops and the same thing happened: I couldn't remotely wake up my laptop as the lights on the Ethernet USB Adapter turned off when I put the laptop on hibernate or sleep mode.
     
  4. managed

    managed Trusted Advisor Spam Fighter

    Joined:
    May 24, 2003
    Messages:
    12,611
    First Name:
    Allan
    There may be a setting in the Bios to enable/disable Wake On Lan, if so make sure it's enabled.
     
  5. techaurelius

    techaurelius Thread Starter

    Joined:
    Wednesday
    Messages:
    6
    Hi managed, I have that option explicitly shown in the BIOS section on my Windows 7 laptop. I enabled that and the lights still did not appear on my Ethernet USB Adapter and I could not remotely wake that laptop up. For my Windows 10 laptop, I switched the option to "Yes" for Touch Pad S3 Wake-up and USB S3 Wake-up and USB Charging in the BIOS section and that didn't work either. In the BIOS section for my Windows 10 laptop, I don't see a Wake On LAN feature explicitly shown.
     
  6. Couriant

    Couriant Trusted Advisor

    Joined:
    Mar 26, 2002
    Messages:
    34,122
    First Name:
    James
    Does the machine have a USB port specifically to charge while turned off? It should have a lightning icon next to it or a battery icon. depending on the manufacturer.
     
  7. managed

    managed Trusted Advisor Spam Fighter

    Joined:
    May 24, 2003
    Messages:
    12,611
    First Name:
    Allan
    I'm thinking the Bios may not support WOL at all because there is no built-in ethernet port.
     
  8. techaurelius

    techaurelius Thread Starter

    Joined:
    Wednesday
    Messages:
    6
    My Windows 7 laptop has an Ethernet port and the Wake On LAN feature, so I was able to remotely wake it on when I plugged in my Ethernet cable directly into that port. Both my Windows 7 and Windows 10 laptops have a USB 3.0 port for charging. I was able to charge my phone when plugging it in with my USB cable into either port while both laptops were in hibernate or sleep mode. I'm trying to get Wake On LAN to work on my Windows 10 laptop which does not have an Ethernet port like here:
     
  9. Couriant

    Couriant Trusted Advisor

    Joined:
    Mar 26, 2002
    Messages:
    34,122
    First Name:
    James
    WOL from what i have seen will only show if there is a built in ethernet network device.
     
  10. techaurelius

    techaurelius Thread Starter

    Joined:
    Wednesday
    Messages:
    6
    My Windows 7 laptop has a built in Ethernet network device. Wake On LAN worked on it when I connected the Ethernet cable directly but not when I used the Ethernet USB Adapter.
     
  11. Couriant

    Couriant Trusted Advisor

    Joined:
    Mar 26, 2002
    Messages:
    34,122
    First Name:
    James
    Yeah, I'm sure WOL is for built in connection. It seems that WOL on Ethernet USB adapter is a hit and miss.. you need power to the dongle but looks like it's not getting it once the machine is asleep... maybe on of the USB Root entries needs to allow power?
     
  12. techaurelius

    techaurelius Thread Starter

    Joined:
    Wednesday
    Messages:
    6
    I disabled the "Allow the computer to turn off this device to save power" option for all USB Root Hub (USB 3.0) items in Device Manager for both my Windows 7 and Windows 10 laptops. Putting either laptop into hibernate or sleep mode while plugging in the Ethernet USB adapter results in the lights turning off for the adapter. But when I plug in my phone's USB charger into the same port while the laptops are in hibernate or sleep mode, my phone charges!
     
  13. Sponsor

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 733,556 other people just like you!

Loading...

Short URL to this thread: https://techguy.org/1236619

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice