1. Computer problem? Tech Support Guy is completely free -- paid for by advertisers and donations. Click here to join today! If you're new to Tech Support Guy, we highly recommend that you visit our Guide for New Members.

Keyboard Doesn't work!!!!!!!Help pleaz

Discussion in 'Hardware' started by GregMarchion, Mar 24, 2002.

Thread Status:
Not open for further replies.
Advertisement
  1. GregMarchion

    GregMarchion Thread Starter

    Joined:
    Nov 20, 2001
    Messages:
    27
    I have a Compaq Presario 5000 series with Win. ME and just recently I cleaned my keyboard and I let it dry for a good 3 hours and now it doesn't work the device Manager says it's there and working but infact it's not!
     
  2. Yankee Rose

    Yankee Rose

    Joined:
    Jul 14, 1999
    Messages:
    1,861
    How did you "clean" it? When you boot your system, do the lights on the keyboard turn on?

    :)
     
  3. Slithy Tove

    Slithy Tove Guest

    Also, make sure you did not unplug both the mouse and keyboard and then re-plug them back into the wrong (each other's) port.
     
  4. GregMarchion

    GregMarchion Thread Starter

    Joined:
    Nov 20, 2001
    Messages:
    27
    I cleaned it with a damp rag. And when I boot the light with 1 above it is on. I can't figure this out.
     
  5. ~Candy~

    ~Candy~ Retired Administrator

    Joined:
    Jan 27, 2001
    Messages:
    103,706
    Does it work in dos?

    Can you get to a c: prompt and try to type something?
     
  6. GregMarchion

    GregMarchion Thread Starter

    Joined:
    Nov 20, 2001
    Messages:
    27
    No not evan in dos
     
  7. ~Candy~

    ~Candy~ Retired Administrator

    Joined:
    Jan 27, 2001
    Messages:
    103,706
    Do you have another machine you can test the keyboard on?

    What kind of keyboard is it? And if you just used a damp cloth...why would you think to leave it dry for 3 hours?
     
  8. GregMarchion

    GregMarchion Thread Starter

    Joined:
    Nov 20, 2001
    Messages:
    27
    Yea all try that now
     
  9. john1

    john1

    Joined:
    Nov 25, 2000
    Messages:
    8,994
    Hi,
    it does sound like a bit of moisture has gotten in.
    You'll have to leave it in the airing cupboard
    for a couple of days.
    A few hours wont do because its an enclosed space
    except for little gaps.

    It is possible that livening it up,
    before it was completely dry,
    may have damaged it.

    But let it dry right out, and hope for the best.

    John
     
  10. Sponsor

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 733,556 other people just like you!

Loading...
Thread Status:
Not open for further replies.

Short URL to this thread: https://techguy.org/73723

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice