Keyboard drivers not loading, can't log into windows

Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

vinbreau

Thread Starter
Joined
Sep 7, 2009
Messages
2
I did something foolish today. While trying to uninstall some Kensington software, I accidentally turned off my keyboard drivers in Windows. Using Autoruns, I deleted 2 entries for keyboard drivers. I kinow one of them to be "kbdclass.sys", not sure what the other one was. The files are still in their homes at e:\Windows\system32\DRIVERS and have not moved. But Windows is no longer launching them at startup. When I boot into my BIOS the keyboard works fine. When i get to the login screen it stops working. To complicate matters, I have only 2 users and a Guest user account. My primary account is passworded, and I can't enter the password. The secondary account does not have admin permissions so even though I can log into it, I can not make any changes to the PS/2 Keyboard Properties. All buttons except for the Driver Details are grayed out.

I thought I would be tricky and open a webpage, copy down letters from a website and restructure them into the password (copy an O and paste it into a document, then a T, etc.) and quickly found the pasteboard does not carry over into the login screen, bummer.

When i run Autoruns in the secondary user I get a message that resources can not be altered. It seems I HAVE to get into the primary user to be able to do anything effective, but the password prevents me.

How can I tell windows to start loading the drivers again?
 

vinbreau

Thread Starter
Joined
Sep 7, 2009
Messages
2
I found a way to change the secondary user to an admin account, so I can now log in and out of an admin user. I uninstalled the drivers 2 yellow ! entries for keyboard and then scanned for hardware changes. They both immediately re-appeared again with yellow !. Next I wanted to restart Windows and try to use F8 to access the Last Known Good Config option... but since the keyboard is the problem the F8 key is ignored and this is not possible.

So then I used System Restore to go back to before I made the change... and this did not fix the unloaded keyboard drivers and nothing has changed.

In the Device Manager, If I right click on "HID Keyboard Device" the device status reads: Windows successfully loaded the device driver for this hardware but cannot find the hardware device. (Code 41)

If I do the same for "PS/2 Keyboard" the status says: Windows cannot start this hardware device because it's configuration information [in the registry] is incomplete or damaged (Code 19)

Still can not figure out how to get the drivers to be acknowledged and loaded at startup.
 
Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 807,865 other people just like you!

Latest posts

Staff online

Members online

Top