LaCie External Burner not working

Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

jaedmc

Thread Starter
Joined
Oct 26, 2007
Messages
1
Okay, so I've been using this LaCie external burner. I maybe burnt like ten DVDs out of it. Then one day I popped in a DVD and it gave me a message about Region. I found this peculiar because the disc was one I got from Netflix, and was NTSC...But the message had an okay button so I pressed okay. After that my burner stopped doing anything. The green light stays on like it's accessing something but it's not reading anything. I tried ejecting it and it wouldn't eject the disc. After a while I just used the tried and true paper clip method and opened it up. Took the disc out, closed it... Nothing. The green light remains. So I uninstalled the drivers. Rolled it back. All that good stuff. Nothing. As a matter of fact, it comes up as a CD-Rom when I plug it in now. And Dev. Manager says it's working properly. I don't want this thing to be dead, because we just got it from my wife's mum. We've hardly used it and it would be lame squared for it to be dead and no warranty. So does any one have an idea. I hope I provided enough information.
 
Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 807,865 other people just like you!

Latest posts

Top