1. Computer problem? Tech Support Guy is completely free -- paid for by advertisers and donations. Click here to join today! If you're new to Tech Support Guy, we highly recommend that you visit our Guide for New Members.

Lag because Chrome processes are in TM's app section

Discussion in 'Windows 10' started by sippher, Nov 16, 2018.

Thread Status:
Not open for further replies.
  1. sippher

    sippher Thread Starter

    Joined:
    Nov 16, 2018
    Messages:
    2
    My Chrome's processes are now in the Apps section instead of the background process section of Task Manager (TM) and it made my laptop lags badly and heats up fast.

    I have been playing using this PC for a long time, and when I play this game (Warframe), I always have my browser (which always has 30+ tabs open, for work stuff) and a torrent client app.

    Usually, I only play 1 hour-ish, and then I close the game to rest. But last night, since there's a new expansion in the game (and it's a very CPU-heavy expansion), I play for 2 hours+. For the last minutes I played, the game was very lagging. That's why I thought "okay, I've been playing for too long, probably I have to restart my laptop to empty the RAM). I closed the game, but the window wouldn't disappear, so I opened Task manager, which was a pain because it wasn't responding too. I deleted the game process from the Task manager, closed my torrent client (without using TM), and when I switched to Chrome window, it was really lagging even though the game & torrent client were already closed. But I managed to close it.

    And when I tried to shut down, it turned out it was "update and shut down", I was like okay, since I wanted to have dinner anyway, so I left my laptop.

    Half an hour later, it was off. The startup was very slow (which wasn't usual). Opening Chrome would make the laptop lag very bad, opening a new tab takes 5 minutes+. I didn't even open my game & torrent client. I thought, oh maybe 30 minutes rest is not enough, so I shut it down and went to bed.
    This morning, while I could start the laptop fast as usual, the Steam "updating steam bar" took forever that I even clicked cancel. Then I opened Chrome, which was also fast. But when I opened the game startup menu (not even the game yet), my laptop was loud as ****, the loudest it's ever been.

    But in Task Manager, I do realize that something is different with Chrome in Task Manager.
    Usually, it only has one Google Chrome in the apps section and lots of Google Chrome in the background process section. But now it has Google Chrome (52) in the apps section
    [​IMG]

    with lots of Google Chromes when I expanded it: [​IMG]

    and none in the "Background process" section. Does all of this happen because it used to not open all of them at once? I do realize that all of my tabs are "active", usually I have to click on that tab (especially older tabs that I haven't clicked at all) to reload & get the page.
    Usually, it's like this.
    [​IMG]
    Image not mine.

    How do I fix this? How do I make Chrome send all those processes & pages to background process again? I've turned off Superfetch, even though I was doing fine with it being on before. Oh and is this normal? 130 mb for Windows Defender?[​IMG] .

    My problem is similar to his https://productforums.google.com/forum/#!topic/chrome/z2ya3elq5xI but too bad there wasn't any solution.
     
  2. lunarlander

    lunarlander

    Joined:
    Sep 21, 2007
    Messages:
    11,821
    It does no harm to have all the Chrome processes under Apps in TM. Whats the version number of your Windows 10 - type winver into Start to find out.
     
  3. sippher

    sippher Thread Starter

    Joined:
    Nov 16, 2018
    Messages:
    2
    winver 1803 (OS Build 17134.407)

    But it's weird though, was it just a coincidence that my laptop uses lots of memory after the chrome processes moved? And another coincidence is, another person also has the same coincidence (laptop uses lots of memory after the processes moved).

    I feel like, my laptop lags/gets hot faster because all of my current tabs are now "active", instead of what they were used to be: "inactive".

    What used to happen: When I opened Chrome, it only loaded the tab after I click on it. Think of Chrome in Android. We can open 50+ tabs in Android without lagging/overheating because the inactive pages doesn't take much of the processor, right?

    But now all of them are always already loaded when I open Chrome, so all of them are considered active & consume lots of memory allocation.
    I really want to know how to set those inactive pages to "background" pages :(
     
As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 733,556 other people just like you!

Loading...
Thread Status:
Not open for further replies.

Short URL to this thread: https://techguy.org/1219219

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice