Lagging in every game and even crash on firefox

Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

Akbaryunal

Thread Starter
Joined
Aug 11, 2019
Messages
3
So i've just upgraded my PC.. there is something i don't understand, read carefully, i will tell every detail..

Before upgrading, in 2012 i had these AMD R7 260x 2gb and i3-3320 3.30ghz 8GB RAM which is surprisingly awesome playing hardcore games like Rainbow Six, GTA V, The Witcher 3, Assassin's creed 3, blackflag, syndicate, hitman 1, MHW, tekken 7, watch dogs 1, and many more..

It's fighting with all these games like never under 30fps (which is bottleneck i think?)

And then in 2019 i decided to upgrade my pc without getting new motherboard and stick with gen 3, i5-2400 3.1ghz and AMD RX580 8GB vram and 8GB RAM

I upgraded all of it's software, i even flash my windows and ugrading bios.

And jump right into Rainbow six and mhw to test run it and.. it's dissapointing super lag.. even when i'm opening a youtube on firefox it's really.. really lagging and unplayable..

Do you guys think it's bottlenecking or not?

Because as comparison, playing Rainbow six with my i3 and r7 is bottleneck too but it's still run at 50-60 fps on custom medium-low setting..

Or does my PSU affect it? I have 550 watt bronze
 
Last edited:
Joined
Sep 21, 2007
Messages
14,069
Did you do a Clean Install of Windows 10 by creating a Windows setup media Generated with MS Media Creation Tool ? Typing 'winver' at the Start menu should pop up a dialog box reporting 'version 1903' .

Did you download the latest GPU drivers from the AMD web site ? ( The MS Windows default ones aren't the latest )
 
Last edited:

Akbaryunal

Thread Starter
Joined
Aug 11, 2019
Messages
3
Did you do a Clean Install of Windows 10 by creating a Windows setup media Generated with MS Media Creation Tool ? Typing 'winver' at the Start menu should pop up a dialog box reporting 'version 1903' .

Did you download the latest GPU drivers from AMD web site ? ( The MS Windows default ones aren't the latest )
I did, i did all of it, i did clean install win 10 and i always download the latest GPU from the web..
I'm stressed out because of this problem..
 
Joined
Sep 21, 2007
Messages
14,069
If opening Youtube with Firefox produces lag then one of the bottleneck is your network speed. You might need to upgrade your Internet Plan with your ISP. Go do a speed test with your browser and compare it with your friends'

A bronze PSU is generally not suitable for gaming and might affect your GPU. But, it should not affect fps. Does your GPU recommend only 550W ? Check the GPU's requirements.
 

Akbaryunal

Thread Starter
Joined
Aug 11, 2019
Messages
3
If opening Youtube with Firefox produces lag then one of the bottleneck is your network speed. You might need to upgrade your Internet Plan with your ISP. Go do a speed test with your browser and compare it with your friends'

A bronze PSU is generally not suitable for gaming and might affect your GPU. But, it should not affect fps. Does your GPU recommend only 550W ? Check the GPU's requirements.
My download is around 10mbps, upload is around 17mbps, and i don't think it's network problem

It says my gpu need at least 500W..
I read in every thread, they even use 500W bronze and still run smoothly..
 
Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 807,865 other people just like you!

Latest posts

Staff online

Top