1. Computer problem? Tech Support Guy is completely free -- paid for by advertisers and donations. Click here to join today! If you're new to Tech Support Guy, we highly recommend that you visit our Guide for New Members.

Laptop not recognize charger while having battery

Discussion in 'Hardware' started by deathvonduel, Jun 17, 2012.

Thread Status:
Not open for further replies.
Advertisement
  1. deathvonduel

    deathvonduel Thread Starter

    Joined:
    Jun 17, 2012
    Messages:
    8
    My laptop all of a sudden today (after about half year of use) refuses to recognize my charger while my battery is plugged in. Here are the exact symptoms:
    1. While battery is plugged in and charger connected, the battery will not charge. If I remove the power cable and plug it back in, it will charge for about 10 seconds before this reoccurs. The battery icon on the lower right of the screen shows as if the power cable is not plugged in. HOWEVER, the hardware cable icon light on the lower right side of my laptop is lit, indicating a connected cable
    2. While battery is plugged in and charger connected, if I remove the battery, the computer will shut down(as if the charger is not connected)

    I am certain that the charger works perfectly fine, I can run the computer without a battery just fine. I'm not entirely sure if this is a hardware or software issue.

    I did not make any system change today or yesterday, nor allow any change that was popped up(the only pop up in the last two day was a jucheck.exe which I clicked no to). This just started happening a hour or so ago for no reason at all for as far as I know, I only noticed because the battery was looking low, thought the cable was insecure but checked it and it was fine. Then I messed around a bit with the cable and battery and found the above

    My computer is a Toshiba satellite P755 S5320
    My operating system is Windows 7 home premium version 6.1 build 7601 service pack 1
     
  2. Elvandil

    Elvandil

    Joined:
    Aug 1, 2003
    Messages:
    51,988
    If it's a year and a half, and you use the battery for power very often, it probably needs to be replaced.

    But you could try calibrating the meter. Just use the laptop or leave it running on battery until it shuts down. Then, put it on the charger and let it charge fully (if it will charge). There may be an app for that at the Toshiba site.

    Though it could be something else, the battery is most likely, and when they go bad, they can exhibit all kinds of strange behaviors that are unexpected and due to its corrupted chemistry.
     
  3. deathvonduel

    deathvonduel Thread Starter

    Joined:
    Jun 17, 2012
    Messages:
    8
    it is half a year, not 1 and half
    and the battery is functioning as a source of power, just not charging.

    The odd thing is, if it's just a battery problem, the computer shouldn't shut down when I pull it out while having power connected, it makes no sense for that to happen as it still have a power supply.
     
  4. Elvandil

    Elvandil

    Joined:
    Aug 1, 2003
    Messages:
    51,988
    Yes, that seems strange but the machine may have switched to a different power state as the battery was charging.

    It sounds like you want the problem to be more serious. It could be, so you may get your wish. But the battery is the most likely problem.

    Do you mean that the battery charges like normal if you can use it for running the machine?
     
  5. deathvonduel

    deathvonduel Thread Starter

    Joined:
    Jun 17, 2012
    Messages:
    8
    the problem is recently discovered, my battery have yet to run out, it have a life time of about 2 and half hour, it's about another half hour until I find out what happens when it run out.

    Additional information:
    I've set my computer to sleep if I close lid when on battery and do nothing if cable is plugged in. When I closed the lid with the battery and the power both plugged in, the computer went into sleep. So the software is not recognizing the power cable

    I don't want the problem to be serious, but I'm kinda doubtful that a battery failure would affect my system to this extend(as opposed to simply everything battery itself stop working etc)
    I'm not even entirely sure if it's a hardware problem, it might be a software issue with my system recognizing the stuff
     
  6. Elvandil

    Elvandil

    Joined:
    Aug 1, 2003
    Messages:
    51,988
    OK. But your light comes on, so you are sure that the machine is getting power, right?

    Yes, it will be interesting to see what happens when the battery runs down.

    Doesn't your machine usually go to sleep when the lid is closed? How does that have anything to do with the power cable?

    (There is no "software" that recognizes the power cable.)
     
  7. deathvonduel

    deathvonduel Thread Starter

    Joined:
    Jun 17, 2012
    Messages:
    8
    The indicator light is on, but I'm not sure if the machine is going to use that power when the battery dies... All I can know from the indicator light is that my power adapter and cable is working fine and connected properly. I've no clue what controls the power in the system, whether it is pure hardware or if software is involved.

    the actions my laptop takes when lid is closed can be customized, and separated between "on battery" and "plugged in"
    I made it so that it won't sleep if it was plugged in and closed the lid. It went to sleep which means from the view of the power setting system, the computer was on battery and not plugged in
     
  8. deathvonduel

    deathvonduel Thread Starter

    Joined:
    Jun 17, 2012
    Messages:
    8
    well, the battery is dead, here is the "log"
    battery went down to 5% critical lvl, system auto hibernate as per setting
    restarted system, keep draining battery, until the system suddenly shuts down in the fashion of no power
    attempt to restart system, keeps getting shut down a few second in, probably still draining on the battery

    now i've removed the battery in order to be able to actually start the computer

    There is definitely something wrong with the power system, not sure if it's the battery itself or some other part
     
  9. deathvonduel

    deathvonduel Thread Starter

    Joined:
    Jun 17, 2012
    Messages:
    8
    Further information:
    I turned off the lap top for the night and put in the battery to let it charge. Now I turn it on in the morning and it's at ~80% charged but will charge no further and starts draining.
    battery indicator is flashing WHITE while power is plugged in and battery inserted now. The user manual says:
    amber when it is being charged
    white when it is fully charged
    unlit if power if charger not connected
    flash amber if it is critically low

    Doesn't say anything about flashing white....

    Guess it is a battery failure but this whole thing is weird
     
  10. Triple6

    Triple6 Rob Moderator

    Joined:
    Dec 26, 2002
    Messages:
    45,574
    Well this is definitely a faulty hardware issue and if its not the power adapter, which it could even though it powers the laptop with no battery; it's not usual for a laptop to charge the battery only or power the laptop only and not charge the battery. But the only way to confirm would be to use a compatible power adapter, if its not the adapter then its the motherboard or DC jack in which case it would be an expensive fix. BUT since the laptop is only 1/2 a year old, have you contacted Toshiba for their warranty tech support? They may send you a new power adapter OR ask to have the laptop sent in for repair.
     
  11. deathvonduel

    deathvonduel Thread Starter

    Joined:
    Jun 17, 2012
    Messages:
    8
    I've asked, they think it might be the battery, so they are sending me a new one and let me try that out. If that don't work out, they are gonna ask me to ship in my laptop for a check up.
    It is within warranty, so luckily those are all free, thou possibly a hassle and take a few weeks.

    After a bit more usage thou, I think it might not be the battery but the adapter. Thou it can power my computer for some usage, my computer experiences sudden shut downs while it is connected sometimes. I fear that it might not be providing sufficient voltage to my computer.
     
  12. deathvonduel

    deathvonduel Thread Starter

    Joined:
    Jun 17, 2012
    Messages:
    8
    well, it's not the adapter...
    I dug up an adapter from an old laptop which have the same voltage and higher amp allowance, which should be fine to use, and the same problem exhibits.
    thou it's possible that the current adapter rly doesn't supply sufficient power for when power usage peeks and requires the battery to fill the gap from time to time so now that battery is out, the whole thing goes south...
    Sad thing is, I cant test that little theory out with the higher amp adapter(which, if functioning properly, shouldn't have this problem) because... that adapter have problems of its own, I have to hold it by hand "just right" for it to be "connected" so... Why am I stuck with a bunch of assorted broken stuff XD

    But as it is, my battery charges semi-fine when laptop is off, and is perfect to use once charged... so unfortunately it's looking more and more like an issue in the laptop itself, which is the worst case scenario (even thou repair should be free, it's still worst case, right?)

    Waiting on the replacement battery to check out theories, keeping my fingers crossed
     
  13. Sponsor

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 733,556 other people just like you!

Loading...
Thread Status:
Not open for further replies.

Short URL to this thread: https://techguy.org/1057414