1. Computer problem? Tech Support Guy is completely free -- paid for by advertisers and donations. Click here to join today! If you're new to Tech Support Guy, we highly recommend that you visit our Guide for New Members.

Laptop only connects when security is off.

Discussion in 'Networking' started by nesc39, Jul 30, 2012.

Thread Status:
Not open for further replies.
Advertisement
  1. nesc39

    nesc39 Thread Starter

    Joined:
    Nov 21, 2008
    Messages:
    6
    Hello I have an HP DV7-1135nr running vista 64bit. Due to lack of space and generally needing to be refreshed, I used my recovery CDs to "factory reset" my laptop to the way it was when I bought it. After it finished I attempted to use the Internet wirelessly and it would only connect locally. I chose to repair the signal in the "network and sharing" window and it said it could not communicate with the DNS server. I plugged in the Ethernet cable and it jumped right online. I used windows update and after 4 hours of updates and restarts, I tried wireless again it only connects locally. Back to ethernet I logged onto HP website and tried to scan my computer for driver updates with there tool but the site was down. I checked my adapter and it is an atheros 5007 but when I searched for atheros or atheros drivers I couldn't find anything that seemed legit. They don't have a website? I read forums and found posts of people shutting off a DHCP broadcast flag with good luck. I found a few èhaving problems with the same adapter as myself but none of this started until I restored it this time. ( I have restored it 2 times before with no problem). My next step was shutting off all the security. It worked and everything was great until i turned the security back on. It reverts back to local only. I tried wpa, wpa2 and no luck. The only thing I can think of is that my drivers are old, I checked the version of windows and it still is on sp1, why hasn't it updated to sp2 yet? Does anyone have a idea of what is wrong.
     
  2. TerryNet

    TerryNet Terry Moderator

    Joined:
    Mar 23, 2005
    Messages:
    69,555
    The following was put together mostly by etaf with a little help from me.

    ------------------------------------------------------------------------
    Atheros Wireless Adapter - AR5007EG & AR5007
    Over the last couple of years we have been seeing a lot of problems with the above adapter, mainly concerning WPA and WPA2 encryption and windows Vista.

    The adapter gets an IP configuration, and shows as connected, but communication is non-existent or sporadic.

    Log into the Router and disable the wireless security and see if you are now able to connect to the internet and surf OK.
    --- Please post back here if that
    works or does not work.


    Here are a number of possible solutions

    --- 1) In Device Manager right click on the wireless adapter and "update driver." That apparently has worked for some posters.

    --- 2) Download and install the latest wireless driver from your laptop manufacturer's web site support section, as some manufactures, appear to now have a working driver available.
    Toshiba - update has worked for some PCs
    HP The latest HP Atheros driver dated Sept 2010 has fixed the issue - so check the driver date, However, that does NOT apply to all HPs / Compaqs machines
    - the poster did an online scan for driver updates on the HP website here HP Product Detection which resulted in a solution. Solved: Can't connect to internet wirelessly - Atheros AR5007 Wifi through Clear Comm - Tech Support Guy Forums

    If you can post the Make and EXACT model of your PC here, along with the windows version you have and we will see if we can find the driver and will post a link as a reply here.

    --- 3) On one occasion re-setting the router back to factory default and re-configuring the router settings has resolved the issue

    --- 4) A few posters here with the same issue have found that the driver from this site ATHEROS drivers for Microsoft Windows resolved the issue
    Threads are here
    Solved: no wireless internet used driver from
    Solved: Used manufacturers updated driver
    Solved: Public Network - Access: Local Only (Please help!) - Tech Support Guy Forums
    Solved: NetGear WNDR3700 Incompatibilty W/ Atheros AR5700 - Tech Support Guy Forums
    Solved: Local connection only when connected to secured wirless - Tech Support Guy Forums


    I do NOT know anything about the site mentioned ATHEROS drivers for Microsoft Windows However, a number of forum members have now successfully used the site to update the driver

    However, if you do decide to try the driver, Please let us know the outcome

    Direct link to the drivers are below
    You only need to click on the green download button labelled " click to download " and wait, the file will download - you do not need to click on any other buttons to get the download started

    AR5007
    Vista 32 Bit
    Drivers for Atheros AR5007 and Windows Vista
    Although this driver has shown up in BSODs (Blue Screen Of Death) on Vista SP2 systems, usually conflicting with updated Vista OS drivers like netio.sys, tcpip.sys and other networking related drivers.

    AR5007EG
    Vista 32 Bit
    Drivers for Atheros AR5007EG and Windows Vista

    Drivers for other windows operating system
    http://www.atheros.cz/atheros-wireless-drivers.php

    Assuming that after all the above the wireless still does not connect to the internet, all I can suggest is to use wireless security of WEP or to get an external USB wireless card.

    You might also bug your laptop's tech support about the problem--maybe people can put pressure on Atheros to find a fix.
    ------------------------------------------------------------------------
     
  3. flavallee

    flavallee Frank Trusted Advisor

    Joined:
    May 12, 2002
    Messages:
    63,648
    Here is the support and software site for the HP Pavilion dv7-1135nr Entertainment Notebook(FS129UA#ABA).

    You should add and save this site in your browser favorites/bookmarks list so you can readily refer to it when needed.

    According to its product specifications section, it came with Windows Vista Home Premium SP1(64-bit) pre-installed.

    That's why it has SP1 after you reset back to its original factory condition.

    You need to go here to download and save the full SP2 upgrade, then burn it off in a CD-R.

    If you ever need to reset that laptop back to its original factory condition again, you'll have the CD-R handy to install the SP2 upgrade afterwards.

    --------------------------------------------------------------

    Are you positive that laptop has an Atheros AR5007 wireless device and not a Broadcom 4321AG/4322AG wireless device?

    This is the only wireless driver listed for it for Windows Vista(64-bit).

    --------------------------------------------------------------
     
  4. flavallee

    flavallee Frank Trusted Advisor

    Joined:
    May 12, 2002
    Messages:
    63,648
    TerryNet:

    That's some very good informstion to know about that wireless adapter with Windows Vista.

    Does it have the same issue with Windows 7?

    -----------------------------------------------------------
     
  5. TerryNet

    TerryNet Terry Moderator

    Joined:
    Mar 23, 2005
    Messages:
    69,555
    Not sure. Think that we've only seen three theads with that combination, and the problem and fix (if any) were not conclusive.
     
  6. flavallee

    flavallee Frank Trusted Advisor

    Joined:
    May 12, 2002
    Messages:
    63,648
    Okay, thanks. My daughter's Toshiba laptop has an Atheros AR5005G wireless device and doesn't appear to have connection or throughput issues. It's running Windows XP though and not Windows Vista.

    ------------------------------------------------------------

    nesc39:

    You still out there?

    ------------------------------------------------------------
     
  7. nesc39

    nesc39 Thread Starter

    Joined:
    Nov 21, 2008
    Messages:
    6
    SOLVED Hey guys thank you so much!!!! i went to that atheros.cz site on my own last night and was pulling my hair out because i had no idea how to download the drivers. You have to click on the the blue checkmark that is in the same column as your operating software....just in case anyone else is as dumb as me. So it ended up taking 8 hours to download all the microsoft updates. I wasnt seeing the SP2 update earlier because you I had to download a bunch of other updates first. What ended up solving my issue was updating the atheros 5007 driver. As soon as it finished installing i pulled out the ethernet cable and cha ching it worked perfect. THANKS
     
  8. etaf

    etaf Wayne Moderator

    Joined:
    Oct 2, 2003
    Messages:
    55,917
    the link should have taken you directly to the vista download sheet - just checked

    for the link under
    Drivers for other windows operating system

    i'll change the script so its clearer for the links - thanks for letting us know

    EDIT - updated instructions
     
  9. Sponsor

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 733,556 other people just like you!

Loading...
Thread Status:
Not open for further replies.

Short URL to this thread: https://techguy.org/1063157