1. Computer problem? Tech Support Guy is completely free -- paid for by advertisers and donations. Click here to join today! If you're new to Tech Support Guy, we highly recommend that you visit our Guide for New Members.

Laptop says it's connected but I can't get online

Discussion in 'Networking' started by babymable, Jun 15, 2011.

Thread Status:
Not open for further replies.
  1. babymable

    babymable Thread Starter

    Oct 8, 2010
    My problem is that we moved house and had to wait for our new internet to be connected in the meantime I used my iphone to tether but now that we have our internet connection back my laptop won't work with wireless. It says it's connected and excellent strength but when I try to open a page it says Page Cannot be Displayed.
    I know it's not the router because our PC and PS3 is connecting fine, and I can connect to the internet on my laptop via a ethernet cable. My drivers are updated and when I run a check it says the device is working properly. The IP address is correct and I have the correct SSID and Network key. I don't know what else I can try. I have contacted my internet supplier and the ran through everything they they could think of and nothing worked. Any suggestions !!l

    It's been a year and I still can't find a solution

    Thought I should mention that I have reformatted my laptop as well thinking that, that may be the problem but it still didn't work.
    I previously had a thread but it was closed you can view it here to see what I have tried already http://forums.techguy.org/networking/955092-laptop-connects-wireless-but-cant.html
  2. pedroguy


    Jan 28, 2001
    If you are still using the Atheros wireless adapter,
    Here is what we know about this adapter.
    Seems to boil down to encryption or drivers:
    Courtesy of ETAF and Terrynet on the Networking Forum:

    Atheros AR5007EG & AR5007
    We have recently been seeing a lot of problems with the above adapters over the last few months, mainly concerning WPA and WPA2 encryption and windows Vista.

    The adapter gets an IP configuration, and shows as connected, but communication is non-existent or sporadic.

    Log into the Router and disable the wireless security and see if you are now able to connect to the internet and surf OK.
    --- Please post back here if that works or does not work.

    Here are a number of possible solutions

    --- 1) In Device Manager right click on the wireless adapter and "update driver." That apparently has worked for some posters.

    --- 2) Download and install the latest wireless driver from your laptop manufacturer's web site support section, as some manufactures, appear to now have a working driver available.
    Toshiba - update has worked for some PCs
    HP The latest HP Atheros driver dated Sept 2010 has fixed the issue - so check the driver date, However, that does NOT apply to all HPs / Compaqs machines
    - the poster did an online scan for driver updates on the HP website here HP Product Detection which resulted in a solution. Solved: Can't connect to internet wirelessly - Atheros AR5007 Wifi through Clear Comm - Tech Support Guy Forums

    If you can post the Make and EXACT model of your PC here, along with the windows version you have and we will see if we can find the driver and will post a link as a reply here.

    --- 3) On one occasion re-setting the router back to factory default and re-configuring the router settings has resolved the issue

    --- 4) A few posters here with the same issue have found that the driver from this site ATHEROS drivers for Microsoft Windows resolved the issue
    Threads are here
    Solved: Public Network - Access: Local Only (Please help!) - Tech Support Guy Forums
    Solved: NetGear WNDR3700 Incompatibilty W/ Atheros AR5700 - Tech Support Guy Forums
    Solved: Local connection only when connected to secured wirless - Tech Support Guy Forums
    Solved: Unidentified Network - Tech Support Guy Forums
    Unidentified Network

    I do NOT know anything about the site mentioned ATHEROS drivers for Microsoft Windows

    However, if you do decide to try the driver, Please let us know the outcome

    Direct link to the drivers are below
    You only need to click on the green download button labelled " click to download " and wait, the file will download - you do not need to click on any other buttons to get the download started

    Vista 32 Bit
    Drivers for Atheros AR5007 and Windows Vista
    Although this driver has shown up in BSODs (Blue Screen Of Death) on Vista SP2 systems, usually conflicting with updated Vista OS drivers like netio.sys, tcpip.sys and other networking related drivers.

    Vista 32 Bit
    Drivers for Atheros AR5007EG and Windows Vista

    Assuming that after all the above the wireless still does not connect to the internet, all I can suggest is to use wireless security of WEP or to get an external USB wireless card.
  3. babymable

    babymable Thread Starter

    Oct 8, 2010
    I disabled wireless security - didn't work
    I switched to WEP security- didn't work
    Tried updating driver, says I already have the most up to date version
    I will look into the external USB wireless card

    Thanks for trying to help thp
  4. pedroguy


    Jan 28, 2001
    Ok:please let us know.
As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 733,556 other people just like you!

Thread Status:
Not open for further replies.

Short URL to this thread: https://techguy.org/1002385