1. Computer problem? Tech Support Guy is completely free -- paid for by advertisers and donations. Click here to join today! If you're new to Tech Support Guy, we highly recommend that you visit our Guide for New Members.

Laptop screen dying - more info

Discussion in 'Hardware' started by Xlore, Nov 9, 2008.

Thread Status:
Not open for further replies.
  1. Xlore

    Xlore Thread Starter

    Joined:
    Aug 27, 2008
    Messages:
    18
    Hi. Not too long ago I posted about my laptop screen and how it was dying. If you didn't read it, I'll explain it again.

    A long time ago, a strip of pixels on my laptop screen half died. There was colour in them, but the colour was lighter than what should have been displayed. I left it and thought not much of it. A week or two later, around 15% of the total screen "died". It stopped showing what it was meant to be showing, and instead it either displayed just a big black bunch of pixels, or strands of colourful pixels. I was annoyed at this. A few days later another 15% of the screen died on me. Right next to the other lot that died (all on the left side of the screen). It did the same - stayed black, however it occasionally flickered on startup, then died again. Yesterday another bunch of pixels went, making half the screen 'damaged'.

    Now, the first part that went always shows coloured lines from the top of the screen to the bottom. The colours and amount change. The second part was half wanting to work yesterday. It was showing distorted parts of my desktop and if I moved a window it would also move on the distorted part. The third part just flickers from grey to black constantly.

    I plugged my dads computer screen into my laptop and I can view the desktop perfectly without implications on it, so it's not the motherboard or some video card thing (not the best at computers here). I concluded that the (laptop) screen itself isn't dodgy/dead/stuck, because as I said, pixels come and go on the screen, yesterday it even showed part of the desktop but distorted.

    All I can imagine it is is some sort of dodgy or faulty wiring somewhere in the connection from the thing that sends what to display to the screen.

    Can anybody help me, either by telling me what the problem could be or how to fix it?

    Sorry for the life story, just making it as detailed as possible.
     
As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 733,556 other people just like you!

Loading...
Thread Status:
Not open for further replies.

Short URL to this thread: https://techguy.org/767473

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice