Laptop Screen is Black

Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

NIKEZ

Thread Starter
Joined
Mar 31, 2010
Messages
56
So I was using an external hard drive to transfer some files from my desktop to my laptop. I was transferring files to the external hard drive when it had some sort of error; can't remember specifically what it was. I decided to plug in a laptop charger into the external driver, then plugged the usb back into the drive. I suddenly heard the external hard drive working like crazy, then there was this smell that smelled like paint coming from the external hard drive. Holy crap, did I just fry it? I didn't notice the smell at first. I also can't say that the smell was too foul... Anyway, my computer said that the external hard drive was installed, but I can't seem to find it on My Computer. So I thought, whatever, I have most of the files I needed anyway. I unplugged the usb from the drive and plugged it into the drive on the laptop. Then holy crap, the laptop fan went off like mad, almost 10 times faster then it was going at the moment. The laptop screen went green, then the entire thing turned off. By then I found out that it was a bad idea to plug a laptop charger into an external hard drive, then into a laptop. What the hell was I thinking?
I turned the laptop back on. Okay, the power supply and motherboard is working. The lights turn on when I press the power button, some other light turns on whenever I plugged in a charger for the laptop. Everything seems to be functioning, except that the laptop screen is black and there's nothing I can do to make the screen work. I tried plugging a monitor up with a laptop, but nothing worked. The screen just won't work. I'm using a Hp Compaq CQ60. Any help would be appreciated. Thank you.
 

NIKEZ

Thread Starter
Joined
Mar 31, 2010
Messages
56
Is the external hard drive completely fried as well? My computer makes that noise when a usb is plugged into the port, then it says that it's installed. The light even turns on from the disk enclosure. Could it be that the hard drive itself is only fried, the enclosure, or both.
 

NIKEZ

Thread Starter
Joined
Mar 31, 2010
Messages
56
Forget about the external hard drive; I went ahead and bought a new one. I'm more concern about the laptop.
 
Joined
Jan 31, 2005
Messages
5,146
If you used a charger of different specs than the computer is supposed to have (there are many different voltages, etc) you are probably out of luck.
Sorry
Vicks
 
Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 807,865 other people just like you!

Latest posts

Members online

Top