1. Computer problem? Tech Support Guy is completely free -- paid for by advertisers and donations. Click here to join today! If you're new to Tech Support Guy, we highly recommend that you visit our Guide for New Members.

Laptop will loose network functionality

Discussion in 'Networking' started by nickm926, Apr 13, 2011.

Thread Status:
Not open for further replies.
Advertisement
  1. nickm926

    nickm926 Thread Starter

    Joined:
    Dec 26, 2007
    Messages:
    41
    My Dell Studio 1558, specs: Core i5 2.4Ghz, 4GB DDR3, 640GB HD, Radeon 5470 has a very weird problem. Occasionly, either once a week or twice a day the network functionality will literally dissapear. The icon still displays on the tray but when I click it nothing happens. If I try and connect to the internet it will say there's no internet connection. Also if I try and open the Network and Sharing Centre explorer stops responding and has to be restarted. If I try and shutdown the laptop it will just hang on the Shutting Down splash screen and has to be forced off. The laptop is still IN warranty however I want to fix it myself as I cannot face Dell :p

    Cheers in advance for responses.
     
  2. tkwincru

    tkwincru

    Joined:
    Feb 8, 2011
    Messages:
    79
    Have you tried checking to see if there is an update through Dell for the network card? I had a similar issue. I ended up going out and downloading the network drivers and software, removing the original from my PC and then re-installed the new drivers I had downloaded.

    When doing so, remove the old first, then reboot. This way you can start fresh with the new drivers.

    Hope this helps and let me know.
     
  3. nickm926

    nickm926 Thread Starter

    Joined:
    Dec 26, 2007
    Messages:
    41
  4. pedroguy

    pedroguy

    Joined:
    Jan 28, 2001
    Messages:
    6,523
    Ok:When you searched for drivers did you use your service tag # to do so.? Hard for me to tell from your link
    Also.Are we talking a wired or wireless connection here ?
     
  5. nickm926

    nickm926 Thread Starter

    Joined:
    Dec 26, 2007
    Messages:
    41
    I searched for the drivers specific to my system, will have a look again now as I have been busy. It has lost its wireless funcitionality...again so I tried plugging it in to the router via ethnert and the internet is fine?!
     
  6. Sponsor

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 733,556 other people just like you!

Loading...
Thread Status:
Not open for further replies.

Short URL to this thread: https://techguy.org/991179

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice