1. Computer problem? Tech Support Guy is completely free -- paid for by advertisers and donations. Click here to join today! If you're new to Tech Support Guy, we highly recommend that you visit our Guide for New Members.

Laptop Won't Stay Connected to Router Help!

Discussion in 'Networking' started by wylekaters, Oct 6, 2008.

Thread Status:
Not open for further replies.
Advertisement
  1. wylekaters

    wylekaters Thread Starter

    Joined:
    Sep 4, 2008
    Messages:
    39
    Hi all.
    Until yesterday my internet was working fine. I have a laptop upstairs and a computer downstairs. The computer is directly connected to my Comcast internet and has a Linksys WRT54G router connected to it.

    Now, my internet on the laptop has stopped working. It will briefly connect to my router and the internet will work but then it will just disconnect. It says (connected or not) that the signal strength is excellent. However, when it disconnects randomly, and then searches for available networks, it doesn't always find my router. And when it does, it won't connect or it'll take like 5 minutes, connect, work briefly, and then disconnect. And this whole time the internet on my main computer works perfectly well.

    Can anyone help me figure out a solution to this? Thanks and if you need any additional info let me know.
     
  2. etaf

    etaf Moderator

    Joined:
    Oct 2, 2003
    Messages:
    65,252
    First Name:
    Wayne
    i assume this is the only device you have connected wirelessly

    do you have wireless secruity - if so take this off and see if it still disconnects

    you may want to change channels the wireless uses on the router, use 1,6 or 11
     
  3. wylekaters

    wylekaters Thread Starter

    Joined:
    Sep 4, 2008
    Messages:
    39
    yes this is the only thing I have connected to it and yes I do have security on. I'll try turning it off and see if that works. And currently it's set to channel 6.

    Also I have noticed that it usually disconnects when I actually open the internet, then it disconnects, then it finds it again, connects and the process repeats.

    Anyway, thanks for the response I'll try the security.
     
  4. etaf

    etaf Moderator

    Joined:
    Oct 2, 2003
    Messages:
    65,252
    First Name:
    Wayne
    lets us know results of removing secruity - if still the same change the channel
     
  5. wylekaters

    wylekaters Thread Starter

    Joined:
    Sep 4, 2008
    Messages:
    39
    Okay so right now I'm not my laptop and apparently it's working. I have turned off the WPA security and changed the channel from 6 to 11.

    However, this doesn't really say much because I could do this before. When I think about it, it's not really connecting that's the problem, it's staying connected. Anytime right now it could just disconnect so I guess I'll just wait and see.

    Also, if it is something with the security, what should I do? Should I just leave it unsecured. And if that's the problem, then why is this just happening because I have been using this for about 2 years now.
     
  6. wylekaters

    wylekaters Thread Starter

    Joined:
    Sep 4, 2008
    Messages:
    39
    So, so far it's been working since I changed the channel (from 6 to 11) and turned off the security. I just wanted to give you guys a heads up to say it's good now. I guess I'll leave everything the way it is. Maybe I'll try turning the security back on and see how that works out.
     
  7. etaf

    etaf Moderator

    Joined:
    Oct 2, 2003
    Messages:
    65,252
    First Name:
    Wayne
    yep, turn the secruity back on and see if its a problem

    the channel change may have fixed an interferance problem
     
  8. Sponsor

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 733,556 other people just like you!

Loading...
Thread Status:
Not open for further replies.

Short URL to this thread: https://techguy.org/756652

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice