1. Computer problem? Tech Support Guy is completely free -- paid for by advertisers and donations. Click here to join today! If you're new to Tech Support Guy, we highly recommend that you visit our Guide for New Members.

Laptops lose internet connection

Discussion in 'Windows 10' started by nascarjrfan, Jan 9, 2019.

Thread Status:
Not open for further replies.
Advertisement
  1. nascarjrfan

    nascarjrfan Thread Starter

    Joined:
    Oct 2, 2008
    Messages:
    114
    Both my Windows 10 laptops lose their internet connect when in sleep mode. This happens frequently.
     
  2. lochlomonder

    lochlomonder

    Joined:
    Jul 24, 2015
    Messages:
    2,672
    The OS is most likely turning off the networks cards to save power. Click on the Windows Start button and then type in Device Manager. Click on the icon to open the program to see a list of your hardware drivers. Left-click on the Network Adapters group to expand it, and then locate the one for your laptop (whether it's wired or wireless). Right-click on the driver and choose Properties. Do you have any Power Management tabs? If so, remove the check against "Allow the computer to turn off this device to save power" and then click OK. Close Device Manager.
     
  3. nascarjrfan

    nascarjrfan Thread Starter

    Joined:
    Oct 2, 2008
    Messages:
    114
    [​IMG]

    Which driver?
     
  4. lochlomonder

    lochlomonder

    Joined:
    Jul 24, 2015
    Messages:
    2,672
    If you are connecting the laptops via Ethernet, it'll be the Realtek PCIe GBE Family Controller. If you're connecting wirelessly, it'll be the Realtek RTL8821CE 802.11ac PCIe Adapter.
     
  5. nascarjrfan

    nascarjrfan Thread Starter

    Joined:
    Oct 2, 2008
    Messages:
    114
    Thank you for your response. I did exactly as you instructed.
     
  6. lochlomonder

    lochlomonder

    Joined:
    Jul 24, 2015
    Messages:
    2,672
    You're welcome. Please let me know if this works for you.
     
  7. nascarjrfan

    nascarjrfan Thread Starter

    Joined:
    Oct 2, 2008
    Messages:
    114
    It didn't work.
     
  8. lochlomonder

    lochlomonder

    Joined:
    Jul 24, 2015
    Messages:
    2,672
    Okay, which device do you use to connect? Wired or wireless?
     
  9. nascarjrfan

    nascarjrfan Thread Starter

    Joined:
    Oct 2, 2008
    Messages:
    114
    Wireless
     
  10. sivartk

    sivartk

    Joined:
    Jan 18, 2019
    Messages:
    28
    First Name:
    Travis
    You can also try looking in the Power Options in the Control Panel.

    Start --> Search Control Panel --> Search in the Upper right corner for Power --> Select Edit Power Plan --> Select Change Advanced Power Settings --> Expand Wireless Adapter Settings --> Expand Power Saving Mode --> Setting: Change to Maximum Performance and see if that helps. It should look something like this:

    upload_2019-1-18_20-4-24.png
     

    Attached Files:

  11. dvk01

    dvk01 Moderator Malware Specialist

    Joined:
    Dec 14, 2002
    Messages:
    56,283
    First Name:
    Derek
    That is a very common problem with sleep mode in many devices. It is frequently caused by a router setting and not a Windows setting.
    What happens when you sleep is that the complete system including network connections & IP addresses are stored in memory & on opening the lid & resuming, it tries to reconnect.
    Now many routers use dynamic DHCP allocation and a short lease allocation time or re-allocates the lease on disconnect.
    Check router settings and either give a higher lease expiry time, perhaps 24 hours or even 21 days which is normally the maximum. or change to static IP allocation ( always use this IP with this device in router settings) so the devices always get the same IP address
     
  12. sivartk

    sivartk

    Joined:
    Jan 18, 2019
    Messages:
    28
    First Name:
    Travis
    Maybe but only if you had a lot of devices (almost using all the allotted internal IP addresses on your router) and a short lease time. Mine is 24 hours, but I've never had that problem and my laptop sleeps when not in use...sometimes for several days without use.

    I do agree on assigning static IP's to things such and printers, scanners, servers, etc.
     
  13. Sponsor

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 733,556 other people just like you!

Loading...
Thread Status:
Not open for further replies.

Short URL to this thread: https://techguy.org/1221626

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice