1. Computer problem? Tech Support Guy is completely free -- paid for by advertisers and donations. Click here to join today! If you're new to Tech Support Guy, we highly recommend that you visit our Guide for New Members.

"ld" not working and "i386-rtems-gcc" not installing (MacPorts) on OS X 10.8.2 VMWare

Discussion in 'All Other Software' started by mikebah, Feb 12, 2013.

Thread Status:
Not open for further replies.
  1. mikebah

    mikebah Thread Starter

    Joined:
    Feb 12, 2013
    Messages:
    1
    I have a fundamental problem and I know I will be told to revert to an older version of Mac/VMWare or just to Linux, but I'm so close to get everything working.

    Basically, I just want to be able to do work with assembly language for the Computer Science degree I'm doing at DMU. To do this I have to have installed:
    - Kate (KDE)
    - GDB
    - Insight
    - NASM
    - LD
    I have managed to install Kate, GDB and NASM (using MacPorts) with the ability to install Insight if I can get the linker (ld) up and running.

    Now, the main error message I got was through following these commands (in the Kate terminal) - my program being "eatsyscall.asm:"
    bash-3.2$ nasm -f elf -g -F stabs eatsyscall.asm
    bash-3.2$ ld -m elf_i386 -o eatsyscall eatsyscall.o
    ld: warning: option -m is obsolete and being ignored
    ld: file not found: elf_i386

    I ran "-m elf_i386" due to the fact I am running a 64-bit OS and Jeff Duntemann says so.

    I did an "ld -v," which gave me:
    @(#)PROGRAM:ld PROJECT:ld64-136
    configured to support archs: armv6 armv7 armv7s i386 x86_64
    LTO support using: LLVM version 3.2svn, from Apple Clang 4.2 (build 425.0.24)

    Following this, I basically searched for every MacPort containing "elf_i386" and "i386" and "gcc" and installed every one apart from "i386-rtems-gcc" of which I got an error when attempting to install:
    Michaels-Mac:bin michael$ sudo port install i386-rtems-gcc
    Password:
    ---> Computing dependencies for i386-rtems-gcc
    ---> Building i386-rtems-gcc
    Error: org.macports.build for port i386-rtems-gcc returned: command execution failed
    Please see the log file for port i386-rtems-gcc for details:
    /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org _release_tarballs_ports_cross_i386-rtems-gcc/i386-rtems-gcc/main.log
    To report a bug, follow the instructions in the guide:
    http://guide.macports.org/#project.tickets
    Error: Processing of port i386-rtems-gcc failed


    Have I gone about this the right way? I know it's a Mac retail version I got from a torrent and the video acceleration is not integrated as I thought it would be, but it's still a decent package and it's almost solved all of my woes following the dismissal of dual booting Ubuntu.

    P.S. I do have Xcode and XQuartz installed on this machine - command line tools are enabled.
    Also, if you need to know, I am running VMWare Workstation 9 on Windows 7 Premium (64-bit) on an 8GB RAM 750GB HDD Lenovo IdeaPad Z580.
     
  2. Triple6

    Triple6 Moderator

    Joined:
    Dec 26, 2002
    Messages:
    52,910
    First Name:
    Rob
    Torrent eh? And on non-Apple hardware? That's two things that are not permitted here or by Apple's EULA therefore I'm closing this thread.
     
As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 733,556 other people just like you!

Loading...
Thread Status:
Not open for further replies.

Short URL to this thread: https://techguy.org/1089228

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice