Lenovo Z50 Black Screen, No cursor

SoReal

Thread Starter
Joined
Sep 28, 2020
Messages
2
I have a Lenovo Z50 laptop running Windows 10.
The issue: Upon start-up, I get the Lenovo wording and a loading ring below it. This will last a few minutes before cutting to an all black screen that will remain indefinitely. This issue began after about 2 years of use. I've tried to do a factory reset (which is okay, I want to delete the data anyway). I've tried plugging into multiple outlets, and I've tried using it while plugged in with AND without the battery inserted. I've spent time to charge the battery and tried starting the laptop without it being plugged in, but the results remained the same. I've tried to factory reset through the NOVO button, I've tried to go through system BIOS and boot from a USB (with a factory reset I had downloaded from a different laptop). I've also tried to do the trick with the power button to power flush it, and also turn it off and on 5 times consecutively for a safe reboot mode. I've also tried to use the F8/F11 button upon start up as well. I see no cursor, so I tried connecting to an external monitor via HDMI (before, during, and after start-up for 3 separate instances) and that didn't do anything.

Is it time to smash this thing?

I've just run out of ideas and Google trails to follow. Thanks in advance!
 

Couriant

James
Trusted Advisor
Spam Fighter
Joined
Mar 26, 2002
Messages
37,165
" This will last a few minutes before cutting to an all black screen that will remain indefinitely. "

So it will no longer turn on to any screen? Does the screen looks like it lights up a little? (from pure black to a lighter black)
 

SoReal

Thread Starter
Joined
Sep 28, 2020
Messages
2
" This will last a few minutes before cutting to an all black screen that will remain indefinitely. "

So it will no longer turn on to any screen? Does the screen looks like it lights up a little? (from pure black to a lighter black)
The screen still has a light, so it is in fact still on. The light never turns off. In other words, the display shows a black screen after the Lenovo loading screen (with the rings) and the dimly lit screen stays that way no longer how long I wait.

Sorry about that! Does this help?
 

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 807,865 other people just like you!

Latest posts

Top