1. Computer problem? Tech Support Guy is completely free -- paid for by advertisers and donations. Click here to join today! If you're new to Tech Support Guy, we highly recommend that you visit our Guide for New Members.

linked to missing export advapi32.dll

Discussion in 'Earlier Versions of Windows' started by gvanhouten, Apr 8, 2004.

Thread Status:
Not open for further replies.
  1. gvanhouten

    gvanhouten Thread Starter

    Joined:
    Apr 7, 2004
    Messages:
    5
    Hi all:
    I need your help since I have not been able to find a resolution to this problem. I have a PC running an AMD 1900+ with Win 98SE. I have two CD Rom drives, one regular and another that is a CD RW drive. I have installed Photoshop 7.0 on my machine and it had been working without a problem. I tried to use it last night and I got the following error:

    "Photoshop.exe linked to a missing export advapi32.dll Get effective rights from AclA"

    I therefore thought the dll file had gone bad so I replaced it with a fresh copy. Same problem!!

    I thought the installation went bad, so I uninstalled the program, then reinstalled Photoshop via the regular CD Rom drive and the installation went fine. By the way, I did deactivate the virus program before installation. I then tried to open the program, and I get the above message and another message that a "device is not working". I went into device manager and everything is working fine. Thinking that the regular CD Rom drive was bad, I uninstalled the program, and then installed it using the CD RW drive. Same error message. In uninstalled again, and this time I copied the files from the CD to to c: drive and I then installed from the C: drive. Same error messages. Please help, this has me stumped since the program had worked a couple of month ago without any errors.
    Photoshop website indicates the solution is to re-install the OS. There has to be a easier way to resolve this problem. Please give me detailed explanation showing all the steps I need to take since I am new to this.
    Since I may not check the forum for a while, suggestions can be sent to my email address:
    [email protected]

    Thanks :)
     
  2. Styxx

    Styxx Banned

    Joined:
    Sep 8, 2001
    Messages:
    4,888
    Did you restart the computer between uninstall and re-install.
     
  3. thinkingout

    thinkingout

    Joined:
    Aug 10, 2003
    Messages:
    15
    No responses in this thread... but my problem is similar. I recently started getting this message popping up on my screen, and I can't associate it with any action I am actively doing...
    Box entitled "Error Starting Program",
    Yellow warning triangle, and a message always reading
    "The MSNAPPAU.EXE file is linked to missing export ADVAPI32.DLL: ConvertStringSecurityDescriptorToSecurityDescriptorW. "
    Button labelled OK.
    If I click OK it goes away and returns later.
    If I don't click OK, or move it away it just stays on my screen.
    Windows ME, regularly updated, had all the Windows download updates etc.
     
As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 733,556 other people just like you!

Thread Status:
Not open for further replies.

Short URL to this thread: https://techguy.org/218358

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice