1. Computer problem? Tech Support Guy is completely free -- paid for by advertisers and donations. Click here to join today! If you're new to Tech Support Guy, we highly recommend that you visit our Guide for New Members.

Solved Linux unable to recognise windows partition

Discussion in 'Linux and Unix' started by mohittomar13, Jul 13, 2019.

Thread Status:
Not open for further replies.
Advertisement
  1. mohittomar13

    mohittomar13 Thread Starter

    Joined:
    May 2, 2011
    Messages:
    330
    First Name:
    Mohit Tomar
    I tried to find the solution to this problem today for the whole day but nothing seemed to be matching with the weird problem I'm facing on my system.

    I use Linux in dual boot mode with Windows 10. Though I use windows mostly for gaming but it was getting so slow that I had to do a clean install. So I deleted the existing C drive (partition) the Recovery Partition and the EFI partition. And created a new partition. Then I used windows 10 USB to install the OS. Everything seemed perfect and windows installed without any problem. Later I installed GRUB using the live cd. It was giving an error of "EFI directory not found", but that was obvious as I deleted the old one and the new install created a new EFI with different UUID than what was present in "fstab" of my existing Linux. Anyways I fixed that issue and then both the OS were available on the GRUB menu.

    However, what the problem is neither of my C and D drives is visible to my existing Linux system. In KDE Partition manager it shows both the partition with unknown type filesystem.

    I also tried to disable fast boot in windows 10

    I'm attaching the screenshot and the output of fstab, fdisk -l and lsblk below.


    The output of fdisk -l

    [email protected]:~$ sudo fdisk -l
    [sudo] password for mohit:
    Disk /dev/sda: 931.5 GiB, 1000204886016 bytes, 1953525168 sectors
    Units: sectors of 1 * 512 = 512 bytes
    Sector size (logical/physical): 512 bytes / 4096 bytes
    I/O size (minimum/optimal): 4096 bytes / 4096 bytes
    Disklabel type: gpt
    Disk identifier: FD8815B8-3C75-46D7-BAD1-54182F2E7861

    Device Start End Sectors Size Type
    /dev/sda1 2048 1085439 1083392 529M Windows recovery environment
    /dev/sda2 1085440 1290239 204800 100M EFI System
    /dev/sda3 1290240 1323007 32768 16M Microsoft reserved
    /dev/sda4 1323008 805308415 803985408 383.4G Microsoft basic data
    /dev/sda5 805308416 1811941375 1006632960 480G Microsoft basic data
    /dev/sda6 1811941376 1886334975 74393600 35.5G Linux filesystem
    /dev/sda7 1886334976 1953523711 67188736 32G Linux filesystem

    --------------------------------------------------------------------------------------------------------------------

    Output of lsblk


    [email protected]:~$lsblk
    NAME MAJ:MIN RM SIZE RO TYPE MOUNTPOINT
    sda 8:0 0 931.5G 0 disk
    ├─sda1 8:1 0 529M 0 part
    ├─sda2 8:2 0 100M 0 part /boot/efi
    ├─sda3 8:3 0 16M 0 part
    ├─sda4 8:4 0 383.4G 0 part
    ├─sda5 8:5 0 480G 0 part
    ├─sda6 8:6 0 35.5G 0 part /home/mohit
    └─sda7 8:7 0 32G 0 part /
    sr0 11:0 1 1024M 0 rom

    --------------------------------------------------------------------------------------------------------------------

    These partitions are clearly visible to windows operating system but onlyLinux is not able to find them. I'm talking about /dev/sda4 and 5

    --------------------------------------------------------------------------------------------------------------------
    I also tried to manually (created customMnt as mount point under /mnt directory) mount the partition by explicitly providing the file system type using the mount -t option in the mount command, but I got error, see below:

    [email protected]:~$ sudo mount /dev/sda4 /mnt/customMnt/
    mount: /mnt/customMnt: wrong fs type, bad option, bad superblock on /dev/sda4, missing codepage or helper program, or other error.

    [email protected]:~$sudo mount -t ntfs /dev/sda4 /mnt/customMnt/
    NTFS signature is missing.
    Failed to mount '/dev/sda4': Invalid argument
    The device '/dev/sda4' doesn't seem to have a valid NTFS.
    Maybe the wrong device is used? Or the whole disk instead of a
    partition (e.g. /dev/sda, not /dev/sda1)? Or the other way around?

    --------------------------------------------------------------------------------------------------------------------

    Also, I'm quite new to Linux operating system and still learning to use it, so whenever I face any problem I simply ask. All the so-called knowledge I have of Linux is only because of forums like KubuntuForums and Ubuntu Forums and some of my daily research... :) :)

    Thanks in advance for any help.
     
  2. mohittomar13

    mohittomar13 Thread Starter

    Joined:
    May 2, 2011
    Messages:
    330
    First Name:
    Mohit Tomar
    Screenshots
     

    Attached Files:

  3. mohittomar13

    mohittomar13 Thread Starter

    Joined:
    May 2, 2011
    Messages:
    330
    First Name:
    Mohit Tomar
    Only the HomePart and LinuxRoot are available under Devices section.

    (HomePart is my home directory which is on a separate partition and LinuxRoot is the root partition)
     
  4. mohittomar13

    mohittomar13 Thread Starter

    Joined:
    May 2, 2011
    Messages:
    330
    First Name:
    Mohit Tomar
    The issue is resolved. I will post the complete steps to solve the issue in some time. My laptop battery is about to die. Bye
     
  5. mohittomar13

    mohittomar13 Thread Starter

    Joined:
    May 2, 2011
    Messages:
    330
    First Name:
    Mohit Tomar
  6. Miqw7394

    Miqw7394

    Joined:
    Apr 1, 2016
    Messages:
    164
    First Name:
    Mike
    Just out of curiosity, did you ever check to see whether the 'ntfs-3g' kernel module was being loaded at boot-time? Without this, Linux can't 'see' Windows partitions correctly.

    It's normally a default boot option, though sometimes default modules fail to get loaded...


    Mike. ;)
     
  7. mohittomar13

    mohittomar13 Thread Starter

    Joined:
    May 2, 2011
    Messages:
    330
    First Name:
    Mohit Tomar
    Thanks Mike, but I dont know how to do that. How to check if a kernel module was loaded or not? And not aware of what ntfs-3g is.
     
  8. managed

    managed Trusted Advisor Spam Fighter

    Joined:
    May 24, 2003
    Messages:
    12,246
    First Name:
    Allan
    To see if ntfs-3g is loaded open a terminal and type in the text below then press enter :-
    Code:
    lsmod | grep ntfs-3g
    What version of Linux are you using ?
     
  9. mohittomar13

    mohittomar13 Thread Starter

    Joined:
    May 2, 2011
    Messages:
    330
    First Name:
    Mohit Tomar
    I'm using Kubuntu 18.4 LTS up-to-date. And the above command didn't output anything. Does that mean that ntfs-3g is not loaded? But my partitions are now available for use in Linux file explorer.
     
  10. managed

    managed Trusted Advisor Spam Fighter

    Joined:
    May 24, 2003
    Messages:
    12,246
    First Name:
    Allan
    Yes ntfs-3g isn't loaded - but that just means your linux is using a different way of reading an Ntfs file-system.

    It's not present in Mint or Ubuntu either.
     
  11. mohittomar13

    mohittomar13 Thread Starter

    Joined:
    May 2, 2011
    Messages:
    330
    First Name:
    Mohit Tomar
    Alright then, we have one thing less to worry about.. :LOL::LOL:
     
  12. managed

    managed Trusted Advisor Spam Fighter

    Joined:
    May 24, 2003
    Messages:
    12,246
    First Name:
    Allan
    So that leaves 99 ?! ;)
     
  13. Sponsor

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 733,556 other people just like you!

Loading...
Tags:
Thread Status:
Not open for further replies.

Short URL to this thread: https://techguy.org/1229917

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice