' "Local Area Connection" doesn't have a valid IP configuration' Error

Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

amuzz

Thread Starter
Joined
Aug 24, 2011
Messages
4
I just got my internet hooked up in my new apartment yesterday, and it is not working when plugged directly into my laptop. It worked fine on the installer's laptop, though.
A buddy of mine let me borrow his wireless router and the wireless works fine with that, although if I try to connect wired through it, that does not work either.

It says I'm connected to an unidentified public network and I get the above error when I try to connect. I've tried disabling IPv6, restarting both the modem and my laptop, and updating the ethernet driver, which I could not find (HP dv2715nr is my model and I have windows 7 ultimate).

Below is my ipconfig with the modem plugged in and the wireless turned off. Hope this is enough info and thanks for any help!

Microsoft Windows [Version 6.1.7601]
Copyright (c) 2009 Microsoft Corporation. All rights reserved.

C:\Users\Allan>ipconfig/all

Windows IP Configuration

Host Name . . . . . . . . . . . . : Allan-PC
Primary Dns Suffix . . . . . . . :
Node Type . . . . . . . . . . . . : Hybrid
IP Routing Enabled. . . . . . . . : No
WINS Proxy Enabled. . . . . . . . : No

Wireless LAN adapter Wireless Network Connection:

Media State . . . . . . . . . . . : Media disconnected
Connection-specific DNS Suffix . : Belkin
Description . . . . . . . . . . . : Broadcom 802.11g Network Adapter
Physical Address. . . . . . . . . : 00-1A-73-F8-E0-14
DHCP Enabled. . . . . . . . . . . : Yes
Autoconfiguration Enabled . . . . : Yes

Ethernet adapter Local Area Connection:

Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : NVIDIA nForce Networking Controller
Physical Address. . . . . . . . . : 00-1D-72-4B-37-47
DHCP Enabled. . . . . . . . . . . : Yes
Autoconfiguration Enabled . . . . : Yes
Autoconfiguration IPv4 Address. . : 169.254.171.20(Preferred)
Subnet Mask . . . . . . . . . . . : 255.255.0.0
Default Gateway . . . . . . . . . :
NetBIOS over Tcpip. . . . . . . . : Enabled

Tunnel adapter isatap.Belkin:

Media State . . . . . . . . . . . : Media disconnected
Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : Microsoft ISATAP Adapter
Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
DHCP Enabled. . . . . . . . . . . : No
Autoconfiguration Enabled . . . . : Yes

Tunnel adapter Teredo Tunneling Pseudo-Interface:

Media State . . . . . . . . . . . : Media disconnected
Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : Teredo Tunneling Pseudo-Interface
Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
DHCP Enabled. . . . . . . . . . . : No
Autoconfiguration Enabled . . . . : Yes

Tunnel adapter isatap.{C918BE30-E6B8-44F5-8A73-38F25CC5759B}:

Media State . . . . . . . . . . . : Media disconnected
Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : Microsoft ISATAP Adapter #2
Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
DHCP Enabled. . . . . . . . . . . : No
Autoconfiguration Enabled . . . . : Yes
 
Joined
Jul 29, 2001
Messages
21,334
Have you tried a different ethernet cable? I am assuming you are using a known good CAT5 cable.
 

amuzz

Thread Starter
Joined
Aug 24, 2011
Messages
4
I did actually try another ethernet cable, which also didn't work. Both work going between the modem and the router. This one is really baffling me.

Another bit of information: the last time I can remember the wired port working was about a year ago, and no new major upgrades have been done, besides the usual program updates and windows update.
 
Joined
Feb 9, 2008
Messages
1,862
Some things you can try. Won't hurt and may help.

TCP/IP stack repair options for use with Vista or Windows 7.

Start, All Programs\Accessories and right click on Command Prompt, select "Run as Administrator" to open a command prompt.
or Start, type cmd in the search box and right click on cmd.exe, select "Run as Administrator" to open a command prompt.


In the command prompt window that opens, type type the following commands, each followed by the Enter key:

Reset WINSOCK entries to installation defaults: netsh winsock reset catalog
Reset IPv4 TCP/IP stack to installation defaults. netsh int ipv4 reset reset.log
Reset IPv6 TCP/IP stack to installation defaults. netsh int ipv6 reset reset.log
Reboot the machine.

others would be,

ipconfig /release
ipconfig /renew

Not sure how to change an Unidentified Network from public to private.
 

amuzz

Thread Starter
Joined
Aug 24, 2011
Messages
4
Tried the resets as well as the suggested driver from HP. Neither worked.

Below is the output from the ipconfig release and renew. Got an error during each. Note: I did this while plugged in directly to the modem and connected to the router, which was not connected to the modem. It would give me an error if either the wireless was turned off or the ethernet cable was not plugged in.


Microsoft Windows [Version 6.1.7601]
Copyright (c) 2009 Microsoft Corporation. All rights reserved.

C:\Windows\system32>ipconfig /release

Windows IP Configuration

An error occurred while releasing interface Local Area Connection : An address h
as not yet been associated with the network endpoint.


Wireless LAN adapter Wireless Network Connection:

Connection-specific DNS Suffix . :
Link-local IPv6 Address . . . . . : fe80::ccb5:5586:9c71:446%10
Default Gateway . . . . . . . . . :

Ethernet adapter Local Area Connection:

Connection-specific DNS Suffix . :
Link-local IPv6 Address . . . . . : fe80::28ce:3992:8073:ab14%9
Autoconfiguration IPv4 Address. . : 169.254.171.20
Subnet Mask . . . . . . . . . . . : 255.255.0.0
Default Gateway . . . . . . . . . :

Tunnel adapter isatap.{C918BE30-E6B8-44F5-8A73-38F25CC5759B}:

Media State . . . . . . . . . . . : Media disconnected
Connection-specific DNS Suffix . :

Tunnel adapter Teredo Tunneling Pseudo-Interface:

Media State . . . . . . . . . . . : Media disconnected
Connection-specific DNS Suffix . :

Tunnel adapter isatap.Belkin:

Media State . . . . . . . . . . . : Media disconnected
Connection-specific DNS Suffix . :

C:\Windows\system32>ipconfig /renew

Windows IP Configuration

An error occurred while renewing interface Local Area Connection : unable to con
tact your DHCP server. Request has timed out.

Wireless LAN adapter Wireless Network Connection:

Connection-specific DNS Suffix . : Belkin
Link-local IPv6 Address . . . . . : fe80::ccb5:5586:9c71:446%10
IPv4 Address. . . . . . . . . . . : 192.168.2.2
Subnet Mask . . . . . . . . . . . : 255.255.255.0
Default Gateway . . . . . . . . . : 192.168.2.1

Ethernet adapter Local Area Connection:

Connection-specific DNS Suffix . :
Link-local IPv6 Address . . . . . : fe80::28ce:3992:8073:ab14%9
Autoconfiguration IPv4 Address. . : 169.254.171.20
Subnet Mask . . . . . . . . . . . : 255.255.0.0
Default Gateway . . . . . . . . . :

Tunnel adapter isatap.{C918BE30-E6B8-44F5-8A73-38F25CC5759B}:

Media State . . . . . . . . . . . : Media disconnected
Connection-specific DNS Suffix . :

Tunnel adapter Teredo Tunneling Pseudo-Interface:

Media State . . . . . . . . . . . : Media disconnected
Connection-specific DNS Suffix . :

Tunnel adapter isatap.Belkin:

Media State . . . . . . . . . . . : Media disconnected
Connection-specific DNS Suffix . : Belkin

C:\Windows\system32>
 
Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 807,865 other people just like you!

Latest posts

Members online

Top