1. Computer problem? Tech Support Guy is completely free -- paid for by advertisers and donations. Click here to join today! If you're new to Tech Support Guy, we highly recommend that you visit our Guide for New Members.

Local area connection doesn't have a valid ip configuration

Discussion in 'Networking' started by cesar211, Nov 18, 2016.

Thread Status:
Not open for further replies.
  1. cesar211

    cesar211 Thread Starter

    Joined:
    Nov 18, 2016
    Messages:
    1
    Hello guys.
    I'm here seeking help due to a problem I've been facing for a long time.
    First of all this all started when I was making some researching about how to change mac address. I changed due to the control I had with router's firewall. I first installed a programm that I thought was great and could do that with no problems. I thought wrong, it kinda messed up my wireless connection and from that moment I've started using LAN, once wireless wasn't available anymore (When I go to device manager and to "network adapets" the "802.11 n/g/b Wireless LAN USB Adapter" has a yellow icon with a "!" and when I double click on it the device status says "This device cannot start. (Code 10).
    I wonder if that has any kind of solution, but if it doesn't that's not the main reason why I'm making this thread. The main reason is basically due to a problem that happened to me yesterday. I installed driver booster and noticed that I had a lot of drivers out dated (incluiding some network adapters), so I decided to update them. When all the updates finished, I was no longer able to connect to internet. The yellow icon with a "!" appeared and the first thing I've tried to do to solve it was to run device manager and see if I could roll back the drivers. Some of them I could, some not. It didn't fix it so I tried a system restore and a startup restore which didn't work aswell, it would stay in the initial phase for hours, stuck on an infite load. As I saw there was no way around, I troubleshooted it to see what was the problem with the network and it seems like "Local Area Connection 2 doesn't have a valid ip configuration" was the problem. Made a lot of research, tried a lot of things but noone of those worked, so I'm hoping I can get some help here.
    Appreciate all the help, cheers.
     
  2. metallica5456

    metallica5456 Trusted Advisor

    Joined:
    Apr 1, 2013
    Messages:
    10,241
    First Name:
    Andrew
    First off uninstall Driver Booster, and roll system restore to before you installed it. Next you need to go the the manufacturers webpage for your board and download the drivers for your device, the wifi and Ethernet adapter.
     
  3. Oddba11

    Oddba11

    Joined:
    May 12, 2011
    Messages:
    7,462
    First Name:
    Jim
    Code 10 typically means the drivers won't start. The drivers are missing, the drivers are corrupted, the wrong drivers are installed, etc. Uninstall whatever software you were trying to use, uninstall the wireless adapter, and reboot. Windows may reinstall the drivers on it's own, but if not, you can manually reinstall the wireless drivers. Assuming we are talking about an OEM computer/laptop like a Dell, you can get the drivers from their website.

    Next, don't use driver update software. For the most part, if the hardware is working, leave it alone. If a new driver will fix an issue that you are having, then you can manually download and install that driver.

    What is the brand/model of your computer?
     
As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 733,556 other people just like you!

Loading...
Thread Status:
Not open for further replies.

Short URL to this thread: https://techguy.org/1181197

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice