Logitech mx revolution 5500 bluetooth not working

Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

ranfx

Thread Starter
Joined
Dec 9, 2011
Messages
1
Please help! I can't believe i can't figure this out, it's embarrassing at this point. I'm hoping someone has had a similar experience.

-Downloaded Loitech's Setpoint 6.32 for windows 7 64 bit from here:

http://www.logitech.com/en-us/433/3...lectedcid=3481&WT.z_sp=Product&osid=14&bit=64

-Not working
-Mouse and keyboard show no response when tested after pressing the bluetooth buttons
-The bluetooth usb hub is detected
-In Device Manager, Windows claims I have the latest driver for bluetooth wireless hub
-According to Logitech, I have the latest version of Setpoint
-Setpoint is supposed to have a bluetooth tab for setup as seen here:

http://logitech-en-amr.custhelp.com/app/answers/detail/a_id/20527

-But my Setpoint does not have the bluetooth tab, and is essentially worthless
-Doesn't have the mouse or keyboard tabs either
 
Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 807,865 other people just like you!

Latest posts

Members online

Top