1. Computer problem? Tech Support Guy is completely free -- paid for by advertisers and donations. Click here to join today! If you're new to Tech Support Guy, we highly recommend that you visit our Guide for New Members.

Loss of Important Files (...) During Changing its Partition's Cluster Size

Discussion in 'Hardware' started by iceq2, Sep 23, 2008.

Thread Status:
Not open for further replies.
Advertisement
  1. iceq2

    iceq2 Thread Starter

    Joined:
    Sep 23, 2008
    Messages:
    6
    PLEASE READ THE TOPIC TILL THE END.. I REALLY NEED SOMEONE'S HELP !

    Loss of Important Files Due to a Disconnection of an External USB HD During Changing its Partition's Cluster Size On Onetouch 4

    Heloo

    I have the Maxtor Onetouch 4 external USB harddisk of 500 GBs. It has two partitions, one is 15 GBs, and the other is the rest of the Harddisk's capacity which is I think 461 GBs. Here, I am speaking about the large partition which is Z.
    The partition Z's cluster size is 4 KB, the factory setting. After it has become almost full, with nearly 410 GBs of video files, I have decided to change its cluster size to the maximum 64 KBs , because I belive that having the hardisk stuffed with large files (no less than 500 MBs ) makes it better to have a larger cluster size to ease the access of the files. To change cluster size, I used Paragon Partition Manager version 6, and I made sure it gave No warning regards the loss of the files or them getting corrupted.

    During applying the cluster size change by Paragon, which was made under Windows XP Pro , SP3, where it wasnt necessary according to Paragon to restart the system to make the changes (because drive Z contains No operating systems ), I said, During applying the change, something happened to the USB connection between the Computer and the Onetouch 4 harddisk nearly in the middle of the process. I heard that sound that you hear when you plug out a usb device off the usb port in the PC, then, in a second, I heard the sound that you hear when the USB is plugged in. Namely, something occured that caused the USB drive to plug in and out very quickly in a second or two.
    Here, Paragon Manager showed an error message talking about a connection problem with the USB drive. Later, I have discovered that many of the video files are no longer working. Trying to play them with VLC, Windows Media Player 11, and Windows Media Player Classic (6), the videos (basically AVI-Divx-XviD format) either appear to be playing but no sound or picture, and the video player's slider moves quickly, not matching the real length of the movie, Or the player simply crashes, or Windows Explorer itself crashes.

    What I tried to rollback this problem

    * I have tried to return the partition to its original state, with 4 KiB of cluster size. For this, I tried Norton (Powerquest's) Partition Magic 8.01, but I get an error during the process. I tried Paragon Partition Manager 9 (first time I used version 6), but it doesnt seem to give me the option to change the cluster size without formatting.

    * I used a tool called CDcheck to check the files hashes, where it showed no problem with the files in terms of their hash records, except for some files of the kind NFO, ISO, and MD5, SFV, showing errors because the original files associated with these are non-existent. But it showed no errors with the huge amount of the video files there.

    * I tried to defragment the drive, and defragment the MFT, but didnt help.

    * I also tried to copy some video files which didnt work to another location on a different local HD. The copying was done suxesfuly, but when trying to play it, the same problem, it crashes.

    As I said above, not all the files got corrupt. I didnt examine all of them, but most of them arent working. For your notice, the thing here is not alphabetical, namely, its not that the folders of video files starting with X or W (which come at the end of the alphabetics) are okay, whereas the ones starting with A or B are corrupt. The corrupt files are very random. I could find a corrupt file, and the file that comes directly after it in the alphabetical order is okay and playable. So applying the cluster size change wasnt necessarily done according to the alphabetical order of the files. This might not be useful, but I want you to know all the things I tried to reverse that problem.

    What can I do to fix this problem and restore the very precious collection of videos that I no longer have the original DVDs for, and which I have been collecting for long years now ??

    Thank you for taking the time to read my story, and I wish you can Help me out of this misery.



    Mouad Khateb
    iceq at hotmail co uk
     
  2. arknorth

    arknorth

    Joined:
    Oct 17, 2007
    Messages:
    1,099
    First, I'd give Seagate/Maxtor a yell and see if they have any backup guarantee on their unit - but... (and here's the ugly part)

    That little 4GB partition is like the recovery partition most computers have these days - it contained all the Maxtor's programming and internal drivers - what you probably heard was the USB drivers that were in the One Touch being wiped out by the partition removal, and those of the computer's own drivers taking over when it 'found' a new device, namely, this external HD that wasn't 'there' before (it was 'seeing' the Z drive as it's USB host).

    I would seriously give Maxtor a yell here, as they sometimes can work minor miracles... but I'm kind of afraid of what may have occurred here might be terminal - Always back up things off a Hard Drive if you're going to play with their sizes this way.

    Sorry I can't be of more help here. Anyone else got any ideas?

    A-N
     
  3. RootbeaR

    RootbeaR

    Joined:
    Dec 8, 2006
    Messages:
    4,469
    I think you are SOL. But I could be wrong and it won't be the first, nor the last time, that I have been wrong.

    The alphabetical view you see in the file manager is strictly for your convenience.
    It has nothing to do with placement on disk.
    If I save "Zorro" to my hard drive, it does not put it at the end because it starts with "Z." Nor will it move it to the beginning of the drive because I renamed it "A1 Zorro."

    Think of your files as pictures in a book. The book contains short stories made up of pics. Every page can have two pics on it(each side). The book is in constant motion so that as I add stories, I am sticking in a page wherever I happen to be at that time, keeping track of the location.

    Now my index looks like:
    Mary Had a Little Lamb......Pgs 1,17,23,14,18,2

    To read the picture story, I must follow the index.

    Book is 11X10X2 or 220 cubic inches(ci).
    I decide to change layout of book, but must remain 220ci. I make it 22X10X1.
    I now have half as many pages, so I need to put four pics per side per page.
    Pages 1 & 2 become page 1. Pages 3 & 4 become page 2.

    The link(index) to my original file has not changed. Now I look at my index to read "Mary Had a Little Lamb." Can't be done logically as pages have changed. If there was thirty pages in first layout, there is now only fifteen. Can't read 17,23 or 18 at all and all other pages also contain parts of other stories. Makes it pretty hard to read that picture book. I must start all over and re-index.

    It sounds like that little usb burp may have halted the process and therefore not all clusters were rearranged(eg. You have 11X10X1 + 22X10X1/2). You will need to check each file individually, start to finish, to determine which are corrupt or not.

    You will find it is much easier to determine layout then add files than it is to try and rip that book apart and put back together again in the new format.
     
  4. iceq2

    iceq2 Thread Starter

    Joined:
    Sep 23, 2008
    Messages:
    6
    First Thanx for taking the time to reply

    I have contacted Maxtor two days ago, still waiting for their response, which I wish to be positive.
     
  5. iceq2

    iceq2 Thread Starter

    Joined:
    Sep 23, 2008
    Messages:
    6
    Thank you for your extensive reply buddy

    I am aware of all that you have said, and I know which files are those that got corrupted.. the thing here is that I want to (try to) restore these files.. I dont wanna delete files that I spent much money and effort to acquire... I really dont want to disconnect that HD and put in the drawer with the other three HDs that were full of important stuff and similarly crashed at some point in the past, and still in the qeue, hoping that someday there would be a solution and the date would be restored ... I have really had enough .. everytime I encounter a problem-type that I have never ever heard about ... who could imagine that during a process of changing cluster size, which one may do perhaps two or three times maximum during his whole life, a usb disconnection occurs (which never occured before), and I lost date hust like that ?

    man .. it really sux
     
  6. Sponsor

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 733,556 other people just like you!

Loading...
Thread Status:
Not open for further replies.

Short URL to this thread: https://techguy.org/752678

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice