Lost the "safely remove" icon in the system tray

Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

Jerold

Thread Starter
Joined
Jun 22, 2004
Messages
489
This icon suddenly isn't showing up, so I have to shut down or risk damaging something to get my external USB devices disconnected from the system.

Is there a place in XP Pro that I can enable it?
 
Joined
May 20, 2005
Messages
2,548
Hello,

Attach the drive
Go to Start => Run and type in "devmgmt.msc" {without the quotes}
Locate the USB drive in 'Disk Drives'
Right-click => Properties => Policies tab
Check the radio button 'Optimize for performance'
OK to exit
 

Jerold

Thread Starter
Joined
Jun 22, 2004
Messages
489
Thanks.

Is it worth it to keep it at the quick removal option where you can just rip the cable out instead of the safe removal method that I usually do?
 
Joined
May 20, 2005
Messages
2,548
If you take a read here - scroll down to 'Cache or not' - it might explain it. "Normally" there's no real advantage for speed. As mentioned in the article, I've used the 'Optimize for performance' option which allows me to format the flash drive in NTFS since I often have to transfer mulitiple folders that contain hundreds of small text files, and the transfer time can be reduced from 30 minutes to 2 or 3 minutes.
http://www.uwe-sieber.de/usbstick_e.html

Also see this forum discussion where all agree that you should not enable write caching - this is the 'Optimize for performance' option, i.e. don't select this option.
http://episteme.arstechnica.com/eve/forums/a/tpc/f/24609792/m/583004049731

If you've ever used Windows 2000, you get the dire warning if you just yank the drive out, because of the risk that the data hasn't been written yet, or not completely written. Windows 2000 doesn't have the 'Quick Removal' option which disables write caching.

Quick Removal = write caching disabled = data written directly = yank it out
Performance = write caching enabled = data cached for later writing = Safely Remove (don't yank it out).

Hope this helps.
 
Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 807,865 other people just like you!

Latest posts

Staff online

Top